ar71xx: fix new mktplinkfw image code - flags for sysupgrade vs factory were swapped...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Apr 2015 19:26:30 +0000 (19:26 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Apr 2015 19:26:30 +0000 (19:26 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45281 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index 9459683..8766756 100644 (file)
@@ -57,8 +57,8 @@ define Build/mktplinkfw
                -r $@ \
                -o $@.new \
                -a $(call rootfs_align,$(FILESYSTEM)) \
-               $(if $(findstring sysupgrade,$1),-j -X 0x40000) \
-               $(if $(findstring factory,$1),-j -X 0x40000 -s) \
+               $(if $(findstring sysupgrade,$1),-j -X 0x40000 -s) \
+               $(if $(findstring factory,$1),-j -X 0x40000) \
                $(if $(findstring initramfs,$1),-s -c)
        @mv $@.new $@
 endef