make the rest of the structure for the targets that dont have profiles yet
authorpavlov <pavlov@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 3 Mar 2007 01:22:09 +0000 (01:22 +0000)
committerpavlov <pavlov@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 3 Mar 2007 01:22:09 +0000 (01:22 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6475 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/aruba-2.6/Makefile
target/linux/atheros-2.6/Makefile
target/linux/brcm47xx-2.6/Makefile
target/linux/ixp4xx-2.6/Makefile
target/linux/magicbox-2.6/Makefile
target/linux/pxa-2.6/Makefile
target/linux/rb532-2.6/Makefile
target/linux/sibyte-2.6/Makefile
target/linux/uml-2.6/Makefile
target/linux/x86-2.6/Makefile

index 5d3e19e..c53964d 100644 (file)
@@ -18,4 +18,7 @@ endef
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-madwifi
 
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index 5404902..1700dec 100644 (file)
@@ -18,4 +18,7 @@ endef
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-madwifi
 
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index ca7fd5d..ab79d82 100644 (file)
@@ -19,4 +19,7 @@ endef
 include $(INCLUDE_DIR)/kernel-build.mk
 # DEFAULT_PACKAGES += kmod-switch
 
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index 352671e..5eea6d6 100644 (file)
@@ -15,4 +15,8 @@ define Target/Description
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index b829965..20325a8 100644 (file)
@@ -12,4 +12,8 @@ BOARDNAME:=Magicbox
 FEATURES:=jffs2
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index 94e9601..76ca28e 100644 (file)
@@ -17,4 +17,7 @@ endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
 
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index 6ec9bdc..27569a3 100644 (file)
@@ -12,4 +12,8 @@ BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index 364d116..28b3302 100644 (file)
@@ -12,4 +12,8 @@ BOARDNAME:=SiByte MIPS
 FEATURES:=broken
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))
index 2562410..089ef58 100644 (file)
@@ -24,6 +24,10 @@ FEATURES:=broken
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
+# include the profiles
+-include profiles/*.mk
+
 endif
 
 $(eval $(call BuildKernel))
index 2b8e497..0053396 100644 (file)
@@ -14,5 +14,8 @@ FEATURES:=squashfs jffs2 ext2
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-natsemi
 
+# include the profiles
+-include profiles/*.mk
+
 $(eval $(call BuildKernel))