hostapd: link against librt if eglibc is used
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 24 Feb 2014 15:03:06 +0000 (15:03 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 24 Feb 2014 15:03:06 +0000 (15:03 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39741 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/hostapd/Makefile

index f00472a..7070afd 100644 (file)
@@ -86,6 +86,10 @@ ifneq ($(LOCAL_TYPE),hostapd)
        CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
 endif
 
+ifdef CONFIG_USE_EGLIBC
+  TARGET_LDFLAGS += -lrt
+endif
+
 DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny @(!TARGET_avr32||BROKEN)
 
 define Package/hostapd/Default