kernel: add ohci-platform.ko for 3.11+
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Aug 2014 16:30:52 +0000 (16:30 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Aug 2014 16:30:52 +0000 (16:30 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42288 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/usb.mk

index 96c899a..0b5abdc 100644 (file)
@@ -331,7 +331,10 @@ define KernelPackage/usb-ohci
        CONFIG_USB_OHCI_HCD_OMAP3=y \
        CONFIG_USB_OHCI_HCD_PLATFORM=y
   FILES:=$(LINUX_DIR)/drivers/usb/host/ohci-hcd.ko
-  AUTOLOAD:=$(call AutoLoad,50,ohci-hcd,1)
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.11.0)),1)
+  FILES+=$(LINUX_DIR)/drivers/usb/host/ohci-platform.ko
+endif
+  AUTOLOAD:=$(call AutoLoad,50,ohci-hcd ohci-platform,1)
   $(call AddDepends/usb)
 endef