ramips: Support for Teltonika RUT5XX
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 12:42:48 +0000 (12:42 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 12:42:48 +0000 (12:42 +0000)
Hi Hartmut,

Thanks for your feedback, I have reformated the patch accordingly.

Added support for Teltonika RUT5XX hardware.

Signed-off-by: Steffen Weinreich <steve@weinreich.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40907 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/RUT5XX.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index 075562a..66a0aaa 100755 (executable)
@@ -104,6 +104,9 @@ get_status_led() {
        rt-n56u | wl-330n | wl-330n3g)
                status_led="asus:blue:power"
                ;;
+       rut5xx)
+               status_led="rut5xx:green:status"
+               ;;
        sl-r7205)
                status_led="sl-r7205:green:status"
                ;;
index 341fd5f..1a39bb6 100644 (file)
@@ -97,6 +97,7 @@ case "$FIRMWARE" in
        px4885 | \
        rt-n15 | \
        rt-n56u | \
+       rut5xx | \
        sl-r7205 | \
        v11st-fe | \
        v22rw-2x2 | \
index 7f221f8..4619bef 100755 (executable)
@@ -211,6 +211,9 @@ ramips_board_detect() {
        *"RT-N56U")
                name="rt-n56u"
                ;;
+       *"RUT5XX")
+               name="rut5xx"
+               ;;
        *"Skyline SL-R7205"*)
                name="sl-r7205"
                ;;
index d8098b2..c85ee0f 100755 (executable)
@@ -69,6 +69,7 @@ platform_check_image() {
        rt-n14u | \
        rt-n15 | \
        rt-n56u | \
+       rut5xx | \
        sl-r7205 | \
        tew-691gr | \
        tew-692gr | \
diff --git a/target/linux/ramips/dts/RUT5XX.dts b/target/linux/ramips/dts/RUT5XX.dts
new file mode 100644 (file)
index 0000000..530b8b1
--- /dev/null
@@ -0,0 +1,86 @@
+/dts-v1/;
+
+/include/ "rt3050.dtsi"
+
+/ {
+       compatible = "RUT5XX", "ralink,rt3050-soc";
+       model = "Teltonika RUT5XX";
+
+       palmbus@10000000 {
+               spi@b00 {
+                       status = "okay";
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "n25q128a13";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "n25q128a13";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xfb0000>;
+                               };
+                       };
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "i2c", "jtag", "rgmii", "mdio", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+        ethernet@10100000 {
+                mtd-mac-address = <&factory 0x28>;
+        };
+
+       esw@10110000 {
+               ralink,portmap = <0x3e>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               status {
+                       label = "rut5xx:green:status";
+                       gpios = <&gpio0 14 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 10 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       otg@101c0000 {
+               status = "okay";
+       };
+};
index 19932f6..345b850 100644 (file)
@@ -454,6 +454,8 @@ Image/Build/Profile/RTG32B1=$(call BuildFirmware/Default4M/$(1),$(1),rt-g32-b1,R
 
 Image/Build/Profile/RTN10PLUS=$(call BuildFirmware/Default4M/$(1),$(1),rt-n10-plus,RT-N10-PLUS)
 
+Image/Build/Profile/RUT5XX=$(call BuildFirmware/Default8M/$(1),$(1),rut5xx,RUT5XX)
+
 Image/Build/Profile/SL-R7205=$(call BuildFirmware/Default4M/$(1),$(1),sl-r7205,SL-R7205)
 
 Image/Build/Profile/V22RW-2X2=$(call BuildFirmware/Default4M/$(1),$(1),v22rw-2x2,V22RW-2X2)
@@ -591,6 +593,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/RTG32B1,$(1))
        $(call Image/Build/Profile/RTN10PLUS,$(1))
        $(call Image/Build/Profile/RT-N13U,$(1))
+       $(call Image/Build/Profile/RUT5XX,$(1))
        $(call Image/Build/Profile/SL-R7205,$(1))
        $(call Image/Build/Profile/UR-326N4G,$(1))
        $(call Image/Build/Profile/V22RW-2X2,$(1))