remove support for DEBUG_DIR, it has lost its purpose since STAGING_DIR_ROOT was...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Feb 2010 23:43:05 +0000 (23:43 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Feb 2010 23:43:05 +0000 (23:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19849 3c298f89-4303-0410-b956-a3cf2f4a3e73

Config.in
include/package-debug.mk [deleted file]
include/package.mk
rules.mk

index 30d7eca..b04c65a 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -206,13 +206,6 @@ config DEBUG
        help
                Adds -g3 to the CFLAGS
 
-config DEBUG_DIR
-       bool "Install debugging binaries into a staging directory"
-       default n
-       help
-               This will install all compiled package binaries into build_dir/target-*/debug-*/,
-               useful for cross-debugging via gdb/gdbserver
-
 config IPV6
         bool
         prompt "Enable IPv6 support in packages"
diff --git a/include/package-debug.mk b/include/package-debug.mk
deleted file mode 100644 (file)
index 2a85bfe..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-# 
-# Copyright (C) 2006,2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-ifeq ($(DUMP),)
-  define BuildTarget/debug
-
-    DEBUG_STAMP_$(1) := $(DEBUG_DIR)/stamp/$(1)
-
-    ifdef Package/$(1)/install
-      ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
-        compile: $$(DEBUG_STAMP_$(1))
-      endif
-    endif
-
-    $$(DEBUG_STAMP_$(1)): $(PKG_BUILD_DIR)/.built
-               mkdir -p $(DEBUG_DIR)/stamp
-               $(call Package/$(1)/install,$(DEBUG_DIR))
-               touch $$(DEBUG_STAMP_$(1))
-
-
-  endef
-endif
index 90aa51c..f48c790 100644 (file)
@@ -26,7 +26,6 @@ include $(INCLUDE_DIR)/quilt.mk
 include $(INCLUDE_DIR)/package-defaults.mk
 include $(INCLUDE_DIR)/package-dumpinfo.mk
 include $(INCLUDE_DIR)/package-ipkg.mk
-include $(INCLUDE_DIR)/package-debug.mk
 include $(INCLUDE_DIR)/package-bin.mk
 include $(INCLUDE_DIR)/autotools.mk
 
@@ -179,7 +178,7 @@ endif
     $(Dumpinfo/Package), \
     $(foreach target, \
       $(if $(Package/$(1)/targets),$(Package/$(1)/targets), \
-        $(if $(PKG_TARGETS),$(PKG_TARGETS), ipkg $(if $(CONFIG_DEBUG_DIR),debug)) \
+        $(if $(PKG_TARGETS),$(PKG_TARGETS), ipkg) \
       ), $(BuildTarget/$(target)) \
     ) \
   )
index 74be471..47db7f6 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -80,7 +80,6 @@ STAMP_DIR_HOST=$(BUILD_DIR_HOST)/stamp
 TARGET_ROOTFS_DIR?=$(if $(call qstrip,$(CONFIG_TARGET_ROOTFS_DIR)),$(call qstrip,$(CONFIG_TARGET_ROOTFS_DIR)),$(BUILD_DIR))
 TARGET_DIR:=$(TARGET_ROOTFS_DIR)/root-$(BOARD)
 STAGING_DIR_ROOT:=$(STAGING_DIR)/root-$(BOARD)
-DEBUG_DIR:=$(BUILD_DIR)/debug-$(BOARD)
 BUILD_LOG_DIR:=$(TOPDIR)/logs
 
 TARGET_PATH:=$(STAGING_DIR_HOST)/bin:$(PATH)