ltq-adsl: fix broken autoconf invocation
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Jan 2015 16:53:34 +0000 (16:53 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Jan 2015 16:53:34 +0000 (16:53 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43931 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/lantiq/ltq-adsl/Makefile

index 2a9f0de..26c931e 100644 (file)
@@ -19,6 +19,7 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 PKG_USE_MIPS16:=0
 PKG_CHECK_FORMAT_SECURITY:=0
+PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -84,11 +85,6 @@ endif
 
 EXTRA_CFLAGS = -fno-pic -mno-abicalls -mlong-calls -G 0
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); aclocal && autoconf && automake)
-       $(call Build/Configure/Default)
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/adsl
        $(CP) $(PKG_BUILD_DIR)/src/include/drv_dsl_cpe_*.h $(1)/usr/include/adsl/