kernel: make kmod-gpiofan depend on kmod-thermal to fix build errors
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Dec 2015 16:58:45 +0000 (16:58 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 22 Dec 2015 16:58:45 +0000 (16:58 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47960 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/hwmon.mk

index ca0ff66..ad1c7bf 100644 (file)
@@ -274,7 +274,7 @@ define KernelPackage/hwmon-gpiofan
   KCONFIG:=CONFIG_SENSORS_GPIO_FAN
   FILES:=$(LINUX_DIR)/drivers/hwmon/gpio-fan.ko
   AUTOLOAD:=$(call AutoLoad,60,gpio-fan)
-  $(call AddDepends/hwmon,+kmod-i2c-core)
+  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-thermal)
 endef
 
 define KernelPackage/hwmon-gpiofan/description