[toolchain] gcc: add --with-long-double-128 for SPARC toolchain
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Oct 2012 14:42:41 +0000 (14:42 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Oct 2012 14:42:41 +0000 (14:42 +0000)
This is required in order to build the final compiler.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33739 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/common.mk

index c18a330..53e4635 100644 (file)
@@ -123,6 +123,7 @@ GCC_CONFIGURE:= \
                $(call qstrip,$(CONFIG_EXTRA_GCC_CONFIG_OPTIONS)) \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 --with-abi=64) \
                $(if $(CONFIG_GCC_VERSION_LLVM),--enable-llvm=$(BUILD_DIR_BASE)/host/llvm) \
+               $(if $(CONFIG_sparc),--with-long-double-128) \
 
 ifeq ($(CONFIG_GCC_LLVM),)
   GCC_BUILD_TARGET_LIBGCC:=y