[package] rssileds: improve performance
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Oct 2012 16:22:04 +0000 (16:22 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Oct 2012 16:22:04 +0000 (16:22 +0000)
LEDs brightness is now only updated if the value actually changed, thus reducing
the number of fwrite syscalls significantly.

Signed-off-by: Daniel Golle <dgolle@allnet.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33766 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/rssileds/Makefile
package/network/utils/rssileds/src/rssileds.c

index 8e292df..b572eac 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rssileds
-PKG_VERSION:=0.1
+PKG_VERSION:=0.2
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 2f25c84..60d30f1 100644 (file)
@@ -70,6 +70,32 @@ void log_rules(rule_t *rules)
        }
 }
 
+int set_led(struct led *led, unsigned char value)
+{
+       char buf[8];
+
+       if ( ! led )
+               return -1;
+
+       if ( ! led->controlfd )
+               return -1;
+
+       if ( led->state == value )
+               return 0;
+
+       snprintf(buf, 8, "%d", value);
+
+       rewind(led->controlfd);
+
+       if ( ! fwrite(buf, sizeof(char), strlen(buf), led->controlfd) )
+               return -2;
+
+       fflush(led->controlfd);
+       led->state=value;
+
+       return 0;
+}
+
 int init_led(struct led **led, char *ledname)
 {
        struct led *newled;
@@ -102,8 +128,15 @@ int init_led(struct led **led, char *ledname)
 
        newled->sysfspath = bp;
        newled->controlfd = bfp;
-       
+
        *led = newled;
+
+       if ( set_led(newled, 255) )
+               goto cleanup_fp;
+
+       if ( set_led(newled, 0) )
+               goto cleanup_fp;
+
        return 0;
 
 cleanup_fp:
@@ -124,29 +157,6 @@ void close_led(struct led **led)
        (*led)=NULL;
 }
 
-int set_led(struct led *led, unsigned char value)
-{
-       char buf[8];
-
-       if ( ! led )
-               return -1;
-
-       if ( ! led->controlfd )
-               return -1;
-
-       snprintf(buf, 8, "%d", value);
-
-       rewind(led->controlfd);
-
-       if ( ! fwrite(buf, sizeof(char), strlen(buf), led->controlfd) )
-               return -2;
-
-       fflush(led->controlfd);
-       led->state=value;
-
-       return 0;
-}
-
 
 int quality(const struct iwinfo_ops *iw, const char *ifname)
 {