add further countermeasures against the git core.autocrlf option (fixes #9075)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 May 2012 13:30:54 +0000 (13:30 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 May 2012 13:30:54 +0000 (13:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31650 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/toplevel.mk
scripts/feeds

index 9a60139..721d14c 100644 (file)
@@ -24,6 +24,7 @@ export OPENWRTVERSION
 export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 export LD_LIBRARY_PATH:=$(if $(LD_LIBRARY_PATH),$(LD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
 export DYLD_LIBRARY_PATH:=$(if $(DYLD_LIBRARY_PATH),$(DYLD_LIBRARY_PATH):)$(STAGING_DIR_HOST)/lib
+export GIT_CONFIG_PARAMETERS='core.autocrlf=false'
 
 # prevent perforce from messing with the patch utility
 unexport P4PORT P4USER P4CONFIG P4CLIENT
index b8c6825..2c0baa6 100755 (executable)
@@ -10,6 +10,7 @@ use Cwd 'abs_path';
 
 chdir "$FindBin::Bin/..";
 $ENV{TOPDIR}=getcwd();
+$ENV{GIT_CONFIG_PARAMETERS}="'core.autocrlf=false'";
 
 my $mk=`which gmake`;  # select the right 'make' program
 chomp($mk);            # trim trailing newline