polarssl: Fix build failures due to PKG_NAME != dir name
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 18 Aug 2015 08:37:38 +0000 (08:37 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 18 Aug 2015 08:37:38 +0000 (08:37 +0000)
Packages that depend on PolarSSL fail to build because polarssl's InstallDev
section never actually gets executed because (prior to this patch) the package
name does not match the subdir the package is in (presumably due to upstream
name change).  As a workaround I have changed the package name back to
polarssl and used a new variable SRC_PKG_NAME for the purposes of downloading
the upstream tarball and creating PKG_BUILD_DIR.

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46683 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/polarssl/Makefile

index c7e6036..5d5e857 100644 (file)
@@ -7,15 +7,18 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=mbedtls
+PKG_NAME:=polarssl
+SRC_PKG_NAME:=mbedtls
 PKG_VERSION:=1.3.11
 PKG_RELEASE:=2
 PKG_USE_MIPS16:=0
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
+PKG_SOURCE:=$(SRC_PKG_NAME)-$(PKG_VERSION)-gpl.tgz
 PKG_SOURCE_URL:=https://polarssl.org/download/
 PKG_MD5SUM:=c02ce2e54862d678604794ee484fb59e
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(SRC_PKG_NAME)-$(PKG_VERSION)
+
 PKG_BUILD_PARALLEL:=1
 PKG_LICENSE:=GPL-2.0+