brcm47xx: increase max image size
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Sep 2015 17:55:28 +0000 (17:55 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Sep 2015 17:55:28 +0000 (17:55 +0000)
the trx utile uses a maximum image size of 7.2MB. There are brcm47xx
devices even with serial flash with bigger flash chips, but OpenWrt was
not able to create images for these devices. This patch provides an
additional parameter which increases this limit to 32 MB. There is a
warning in the trx utile code which suggests that bigger images could
overwrite the nvram partition on some devices, but normally the program
writing the image should make sure that it is safe to write it to the
flash.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46872 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm47xx/image/Makefile

index 0582859..8063de0 100644 (file)
@@ -99,6 +99,7 @@ endef
 define Image/Build/trxV2
        $(call Image/Build/CyberTANHead,$(1),$(2),$(3),$(4),$(5),$(if $(6),$(6)))
        $(STAGING_DIR_HOST)/bin/trx \
+               -m 33554432 \
                -2 \
                -o $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(5).noheader.bin \
                -f $(KDIR)/loader.gz \
@@ -113,6 +114,7 @@ endef
 
 define Build/trx-with-loader
        $(STAGING_DIR_HOST)/bin/trx \
+               -m 33554432 \
                -o $@ \
                -f $(KDIR)/loader.gz \
                -f $(word 1,$^) \
@@ -341,10 +343,12 @@ endif
 
 define Image/Build/Initramfs
        $(STAGING_DIR_HOST)/bin/trx \
+               -m 33554432 \
                -o $(BIN_DIR)/$(IMG_PREFIX)-initramfs.trx \
                -f $(KDIR)/loader.gz \
                -f $(KDIR)/vmlinux-initramfs.lzma
        $(STAGING_DIR_HOST)/bin/trx \
+               -m 33554432 \
                -o $(BIN_DIR)/$(IMG_PREFIX)-initramfs-noloader-nodictionary.trx \
                -f $(KDIR)/vmlinux-initramfs-nodictionary.lzma
 endef
@@ -352,14 +356,17 @@ endef
 # $(1): filesystem type.
 define Image/Build
        $(STAGING_DIR_HOST)/bin/trx \
+               -m 33554432 \
                -o $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx \
                -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma \
                $(call trxalign/$(1),$(1))
        $(STAGING_DIR_HOST)/bin/trx \
+               -m 33554432 \
                -o $(BIN_DIR)/$(IMG_PREFIX)-$(1)-noloader-nodictionary.trx \
                -f $(KDIR)/vmlinux-nodictionary.lzma \
                $(call trxalign/$(1),$(1))
        $(STAGING_DIR_HOST)/bin/trx \
+               -m 33554432 \
                -o $(BIN_DIR)/$(IMG_PREFIX)-$(1)-gz.trx \
                -f $(KDIR)/vmlinux.gz \
                $(call trxalign/$(1),$(1))