mpc83xx: create package for the rbppc_cf module
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 26 Dec 2012 10:40:47 +0000 (10:40 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 26 Dec 2012 10:40:47 +0000 (10:40 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34888 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/mpc83xx/modules.mk [new file with mode: 0644]

diff --git a/target/linux/mpc83xx/modules.mk b/target/linux/mpc83xx/modules.mk
new file mode 100644 (file)
index 0000000..dd65d11
--- /dev/null
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/ata-rbppc-cf
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=RB600 Compact Flash support
+  DEPENDS:=@TARGET_mpc83xx
+  KCONFIG:= \
+       CONFIG_PATA_PLATFORM \
+       CONFIG_PATA_RB_PPC
+  FILES:=\
+       $(LINUX_DIR)/drivers/ata/pata_rbppc_cf.ko
+  AUTOLOAD:=$(call AutoLoad,41,pata_rbppc_cf,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-rbppc-cf/description
+  RB600 Compact Flash support.
+endef
+
+$(eval $(call KernelPackage,ata-rbppc-cf))