fix x86 image build order (fixes #3317)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 4 Jun 2008 21:55:25 +0000 (21:55 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 4 Jun 2008 21:55:25 +0000 (21:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11359 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/x86/image/Makefile

index 7af4348..6649670 100644 (file)
@@ -96,9 +96,9 @@ define Image/BuildKernel
 endef
 
 define Image/Build
+       $(call Image/Build/$(1))
        $(call Image/Build/grub,$(1))
        $(call Image/Build/vdi,$(1))
-       $(call Image/Build/$(1))
        $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(1).fs
        $(CP) $(KDIR)/bzImage $(BIN_DIR)/openwrt-$(BOARD)-vmlinuz
 endef