[package] base-files: release an attached loop device on umounting
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 19 Sep 2012 15:13:44 +0000 (15:13 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 19 Sep 2012 15:13:44 +0000 (15:13 +0000)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33477 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/init.d/umount

index 1392752..1d56e9f 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=116
+PKG_RELEASE:=117
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index a4e477e..5a750b9 100755 (executable)
@@ -4,5 +4,5 @@
 STOP=99
 stop() {
        sync
-       umount -a -r
+       umount -a -d -r
 }