ar71xx: add preliminary support for wzr-hp-g450h
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Dec 2011 14:20:51 +0000 (14:20 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Dec 2011 14:20:51 +0000 (14:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29441 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-2.6.39
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-wzr-hp-g450h.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/machtype.h
target/linux/ar71xx/generic/profiles/buffalo.mk
target/linux/ar71xx/image/Makefile

index 22e951d..bb6ceb7 100755 (executable)
@@ -229,6 +229,9 @@ ar71xx_board_detect() {
        *WZR-HP-G300NH)
                name="wzr-hp-g300nh"
                ;;
+       *WZR-HP-G450H)
+               name="wzr-hp-g450h"
+               ;;
        *WHR-HP-G300N)
                name="whr-hp-g300n"
                ;;
index 1de9077..8b69bc5 100755 (executable)
@@ -98,6 +98,7 @@ platform_check_image() {
        nanostation-m | \
        rocket-m | \
        wzr-hp-g300nh | \
+       wzr-hp-g450h | \
        wzr-hp-ag300h | \
        whr-g301n | \
        whr-hp-g300n | \
index 8cca8e2..068a938 100644 (file)
@@ -54,6 +54,7 @@ CONFIG_AR71XX_MACH_WRT160NL=y
 CONFIG_AR71XX_MACH_WRT400N=y
 CONFIG_AR71XX_MACH_WZR_HP_AG300H=y
 CONFIG_AR71XX_MACH_WZR_HP_G300NH=y
+CONFIG_AR71XX_MACH_WZR_HP_G450H=y
 CONFIG_AR71XX_MACH_ZCN_1523H=y
 CONFIG_AR71XX_NVRAM=y
 CONFIG_AR71XX_PCI_ATH9K_FIXUP=y
index f80974b..13d1803 100644 (file)
@@ -136,6 +136,15 @@ config AR71XX_MACH_WZR_HP_AG300H
        select AR71XX_DEV_LEDS_GPIO
        select AR71XX_DEV_USB
 
+config AR71XX_MACH_WZR_HP_G450H
+       bool "Buffalo WZR-HP-G450H board support"
+       select SOC_AR724X
+       select AR71XX_DEV_M25P80
+       select AR71XX_DEV_AP91_PCI if PCI
+       select AR71XX_DEV_GPIO_BUTTONS
+       select AR71XX_DEV_LEDS_GPIO
+       select AR71XX_DEV_USB
+
 config AR71XX_MACH_WZR_HP_G300NH
        bool "Buffalo WZR-HP-G300NH board support"
        select SOC_AR913X
index d64a4ea..2805f19 100644 (file)
@@ -69,4 +69,5 @@ obj-$(CONFIG_AR71XX_MACH_WRT160NL)    += mach-wrt160nl.o
 obj-$(CONFIG_AR71XX_MACH_WRT400N)      += mach-wrt400n.o
 obj-$(CONFIG_AR71XX_MACH_WZR_HP_G300NH)        += mach-wzr-hp-g300nh.o
 obj-$(CONFIG_AR71XX_MACH_WZR_HP_AG300H)        += mach-wzr-hp-ag300h.o
+obj-$(CONFIG_AR71XX_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o
 obj-$(CONFIG_AR71XX_MACH_ZCN_1523H)    += mach-zcn-1523h.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-wzr-hp-g450h.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-wzr-hp-g450h.c
new file mode 100644 (file)
index 0000000..ab6c37c
--- /dev/null
@@ -0,0 +1,85 @@
+/*
+ *  Atheros G450 board support
+ *
+ *  Copyright (C) 2010 Felix Fietkau <nbd@openwrt.org>
+ *  Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#include "machtype.h"
+#include "devices.h"
+#include "dev-m25p80.h"
+#include "dev-ap91-pci.h"
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition wzrhpg450h_partitions[] = {
+       {
+               .name           = "u-boot",
+               .offset         = 0,
+               .size           = 0x0040000,
+               .mask_flags     = MTD_WRITEABLE,
+       }, {
+               .name           = "u-boot-env",
+               .offset         = 0x0040000,
+               .size           = 0x0010000,
+       }, {
+               .name           = "ART",
+               .offset         = 0x0050000,
+               .size           = 0x0010000,
+               .mask_flags     = MTD_WRITEABLE,
+       }, {
+               .name           = "uImage",
+               .offset         = 0x0060000,
+               .size           = 0x0100000,
+       }, {
+               .name           = "rootfs",
+               .offset         = 0x0160000,
+               .size           = 0x1e80000,
+       }, {
+               .name           = "user_property",
+               .offset         = 0x1fe0000,
+               .size           = 0x0020000,
+       }, {
+               .name           = "firmware",
+               .offset         = 0x0060000,
+               .size           = 0x1f80000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct flash_platform_data wzrhpg450h_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .parts          = wzrhpg450h_partitions,
+       .nr_parts       = ARRAY_SIZE(wzrhpg450h_partitions),
+#endif
+};
+
+static void __init wzrhpg450h_init(void)
+{
+       u8 *ee = (u8 *) KSEG1ADDR(0x1f051000);
+       u8 *mac = (u8 *) ee + 2;
+
+       ar71xx_add_device_m25p80_multi(&wzrhpg450h_flash_data);
+
+       ar71xx_add_device_mdio(0, ~BIT(0));
+       ar71xx_init_mac(ar71xx_eth0_data.mac_addr, mac, 0);
+       ar71xx_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ar71xx_eth0_data.speed = SPEED_1000;
+       ar71xx_eth0_data.duplex = DUPLEX_FULL;
+       ar71xx_eth0_data.phy_mask = BIT(0);
+
+       ar71xx_add_device_eth(0);
+
+       ap91_pci_init(ee, NULL);
+}
+
+MIPS_MACHINE(AR71XX_MACH_WZR_HP_G450H, "WZR-HP-G450H", "Buffalo WZR-HP-G450H",
+            wzrhpg450h_init);
index d755a7a..3a9e973 100644 (file)
@@ -76,6 +76,7 @@ enum ar71xx_mach_type {
        AR71XX_MACH_WRT400N,    /* Linksys WRT400N */
        AR71XX_MACH_WZR_HP_AG300H, /* Buffalo WZR-HP-AG300H */
        AR71XX_MACH_WZR_HP_G300NH, /* Buffalo WZR-HP-G300NH */
+       AR71XX_MACH_WZR_HP_G450H, /* Buffalo WZR-HP-G450H */
        AR71XX_MACH_ZCN_1523H_2, /* Zcomax ZCN-1523H-2-xx */
        AR71XX_MACH_ZCN_1523H_5, /* Zcomax ZCN-1523H-5-xx */
 };
index 74530b5..e975eb8 100644 (file)
@@ -27,6 +27,17 @@ endef
 
 $(eval $(call Profile,WZRHPAG300H))
 
+define Profile/WZRHPG450H
+       NAME:=Buffalo WZR-HP-G450H
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WZRHPG450H/Description
+       Package set optimized for the Buffalo WZR-HP-G450H
+endef
+
+$(eval $(call Profile,WZRHPG450H))
+
 define Profile/WHRG301N
        NAME:=Buffalo WHR-G301N
        PACKAGES:=
index 2394e99..ddbbafa 100644 (file)
@@ -807,6 +807,11 @@ define Image/Build/Profile/WZRHPAG300H
        $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-ag300h,$(wzrhpag300h_cmdline),WZR-HP-AG300H)
 endef
 
+wzrhpg450h_cmdline=board=WZR-HP-G450H console=ttyS0,115200
+define Image/Build/Profile/WZRHPG450H
+       $(call Image/Build/Template/$(fs_64k)/$(1),WZRHPG30XNH,wzr-hp-g450h,$(wzrhpg450h_cmdline),WZR-HP-AG450H)
+endef
+
 zcn1523h28_cmdline=board=ZCN-1523H-2 console=ttyS0,115200
 define Image/Build/Profile/ZCN1523H28
        $(call Image/Build/Template/$(fs_64k)/$(1),Zcomax,zcn-1523h-2-8,$(zcn1523h28_cmdline))
@@ -875,6 +880,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/WHRHPGN,$(1))
        $(call Image/Build/Profile/WZRHPG300NH,$(1))
        $(call Image/Build/Profile/WZRHPAG300H,$(1))
+       $(call Image/Build/Profile/WZRHPG450H,$(1))
        $(call Image/Build/Profile/ZCN1523H28,$(1))
        $(call Image/Build/Profile/ZCN1523H516,$(1))
 endef