oprofile: drop kmod-oprofile dependency, it uses the perf API now
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 6 Oct 2015 12:32:59 +0000 (12:32 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 6 Oct 2015 12:32:59 +0000 (12:32 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47147 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/devel/oprofile/Makefile
package/devel/oprofile/patches/200-add_mips_1004kc.patch [new file with mode: 0644]

index b1808a3..cdeeec2 100644 (file)
@@ -32,7 +32,7 @@ define Package/oprofile
   CATEGORY:=Development
   TITLE:=OProfile System Profiler
   URL:=http://oprofile.sourceforge.net
-  DEPENDS:=+libpopt +kmod-oprofile +libstdcpp +objdump +librt @(!TARGET_uml||BROKEN)
+  DEPENDS:=+libpopt +libstdcpp +objdump +librt @(!TARGET_uml||BROKEN)
 endef
 
 define Package/oprofile/description
diff --git a/package/devel/oprofile/patches/200-add_mips_1004kc.patch b/package/devel/oprofile/patches/200-add_mips_1004kc.patch
new file mode 100644 (file)
index 0000000..038cd7d
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/libop/op_cpu_type.c
++++ b/libop/op_cpu_type.c
+@@ -609,6 +609,7 @@ static struct mips_cpu_descr mips_cpu_de
+       { .key = "MIPS 25Kc", .value = "mips/25K" },            /* CPU_25KF */
+       { .key = "MIPS 34Kc", .value = "mips/34K" },            /* CPU_34K */
+       { .key = "MIPS 74Kc", .value = "mips/74K" },            /* CPU_74K */
++      { .key = "MIPS 1004Kc", .value = "mips/1004K" },        /* CPU_1004K */
+       { .key = "MIPS M14Kc", .value = "mips/M14Kc" },         /* CPU_M14KC */
+       { .key = "RM9000", .value = "mips/rm9000" },            /* CPU_RM9000 */
+       { .key = "R10000", .value = "mips/r10000" },            /* CPU_R10000 */