ar71xx: preliminary support for the TL-WR1043ND
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Dec 2009 12:46:25 +0000 (12:46 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Dec 2009 12:46:25 +0000 (12:46 +0000)
Adds board support for the TP-Link TL-WR1043ND Based on the Atheros AP81 platform.
Presently the RTL8366RB switch support is missing due to no driver.
The ethernet works with 5 ports@1Gbit but is missing vlan support.

Hope Ive done this right, First time submiting a patch.

Signed-off-by: Andrew Tarabaras <andrew@advancedtechnologies.com.au>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18696 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/config-2.6.30
target/linux/ar71xx/config-2.6.31
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-wr1043nd.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
target/linux/ar71xx/files/arch/mips/include/asm/mach-ar71xx/ar71xx.h
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/profiles/tp-link.mk
tools/firmware-utils/src/mktplinkfw.c

index 3cedfdc..914c265 100644 (file)
@@ -14,6 +14,7 @@ CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_PB44=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
+CONFIG_AR71XX_MACH_TL_WR1043ND=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
 CONFIG_AR71XX_MACH_TL_WR941ND=y
 CONFIG_AR71XX_MACH_UBNT=y
index 0615a50..fa9f5dd 100644 (file)
@@ -17,6 +17,7 @@ CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
 CONFIG_AR71XX_MACH_TL_WR941ND=y
+CONFIG_AR71XX_MACH_TL_WR1043ND=y
 CONFIG_AR71XX_MACH_UBNT=y
 CONFIG_AR71XX_MACH_WNDR3700=y
 CONFIG_AR71XX_MACH_WNR2000=y
index c68115b..c06038c 100644 (file)
@@ -71,6 +71,10 @@ config AR71XX_MACH_TL_WR941ND
        bool "TP-LINK TL-WR941ND support"
        default y
 
+config AR71XX_MACH_TL_WR1043ND
+       bool "TP-LINK TL-WR1043ND support"
+       default y
+
 config AR71XX_MACH_TEW_632BRP
        bool "TRENDnet TEW-632BRP support"
        default y
index 8e37c05..a7871a2 100644 (file)
@@ -26,6 +26,7 @@ obj-$(CONFIG_AR71XX_MACH_RB_4XX)      += mach-rb-4xx.o
 obj-$(CONFIG_AR71XX_MACH_TEW_632BRP)   += mach-tew-632brp.o
 obj-$(CONFIG_AR71XX_MACH_TL_WR741ND)   += mach-tl-wr741nd.o
 obj-$(CONFIG_AR71XX_MACH_TL_WR941ND)   += mach-tl-wr941nd.o
+obj-$(CONFIG_AR71XX_MACH_TL_WR1043ND)  += mach-tl-wr1043nd.o
 obj-$(CONFIG_AR71XX_MACH_UBNT)         += mach-ubnt.o
 obj-$(CONFIG_AR71XX_MACH_WNDR3700)     += mach-wndr3700.o
 obj-$(CONFIG_AR71XX_MACH_WNR2000)      += mach-wnr2000.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-wr1043nd.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-tl-wr1043nd.c
new file mode 100644 (file)
index 0000000..e67282e
--- /dev/null
@@ -0,0 +1,136 @@
+/*
+ *  TP-LINK TL-WR1043ND board support
+ *
+ *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+#include <linux/input.h>
+
+#include <asm/mips_machine.h>
+
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#include "devices.h"
+
+#define TL_WR1043ND_GPIO_LED_SYSTEM     2
+#define TL_WR1043ND_GPIO_LED_QSS        5
+
+#define TL_WR1043ND_GPIO_BTN_RESET      3
+#define TL_WR1043ND_GPIO_BTN_QSS        7
+
+#define TL_WR1043ND_BUTTONS_POLL_INTERVAL     20
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition tl_wr1043nd_partitions[] = {
+       {
+               .name           = "u-boot",
+               .offset         = 0,
+               .size           = 0x020000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "kernel",
+               .offset         = 0x020000,
+               .size           = 0x140000,
+       } , {
+               .name           = "rootfs",
+               .offset         = 0x160000,
+               .size           = 0x690000,
+       } , {
+               .name           = "art",
+               .offset         = 0x7f0000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "firmware",    
+               .offset         = 0x020000,
+               .size           = 0x7d0000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct flash_platform_data tl_wr1043nd_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+        .parts          = tl_wr1043nd_partitions,
+        .nr_parts       = ARRAY_SIZE(tl_wr1043nd_partitions),
+#endif
+};
+
+static struct spi_board_info tl_wr1043nd_spi_info[] = {
+       {
+               .bus_num        = 0,
+               .chip_select    = 0,
+               .max_speed_hz   = 25000000,
+               .modalias       = "m25p80",
+               .platform_data  = &tl_wr1043nd_flash_data,
+       }
+};
+
+static struct gpio_led tl_wr1043nd_leds_gpio[] __initdata = {
+       {
+               .name           = "tl-wr1043nd:green:system",
+               .gpio           = TL_WR1043ND_GPIO_LED_SYSTEM,
+               .active_low     = 1,
+       }, {
+               .name           = "tl-wr1043nd:red:qss",
+               .gpio           = TL_WR1043ND_GPIO_LED_QSS,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_button tl_wr1043nd_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = BTN_0,
+               .threshold      = 5,
+               .gpio           = TL_WR1043ND_GPIO_BTN_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "qss",
+               .type           = EV_KEY,
+               .code           = BTN_1,
+               .threshold      = 5,
+               .gpio           = TL_WR1043ND_GPIO_BTN_QSS,
+               .active_low     = 1,
+       }
+};
+
+static void __init tl_wr1043nd_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+
+       ar71xx_set_mac_base(mac);
+
+       ar71xx_add_device_mdio(0x0);
+
+       ar71xx_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ar71xx_eth0_data.phy_mask = 0x0;
+       ar71xx_eth0_data.speed = SPEED_1000;
+       ar71xx_eth0_data.duplex = DUPLEX_FULL;
+       
+       ar71xx_add_device_eth(0);
+       
+       ar71xx_add_device_usb();
+       
+       ar71xx_add_device_spi(NULL, tl_wr1043nd_spi_info,
+                                       ARRAY_SIZE(tl_wr1043nd_spi_info));
+
+       ar71xx_add_device_leds_gpio(-1, ARRAY_SIZE(tl_wr1043nd_leds_gpio),
+                                       tl_wr1043nd_leds_gpio);
+
+       ar71xx_add_device_gpio_buttons(-1, TL_WR1043ND_BUTTONS_POLL_INTERVAL,
+                                       ARRAY_SIZE(tl_wr1043nd_gpio_buttons),
+                                       tl_wr1043nd_gpio_buttons);
+       ar91xx_add_device_wmac();
+}
+
+MIPS_MACHINE(AR71XX_MACH_TL_WR1043ND, "TP-LINK TL-WR1043ND", tl_wr1043nd_setup);
index cc0d5ae..b0a51cf 100644 (file)
@@ -71,6 +71,9 @@ static struct board_rec boards[] __initdata = {
                .name           = "TL-WR941ND",
                .mach_type      = AR71XX_MACH_TL_WR941ND,
        }, {
+               .name           = "TL-WR1043ND",
+               .mach_type      = AR71XX_MACH_TL_WR1043ND,
+       }, {
                .name           = "UBNT-RS",
                .mach_type      = AR71XX_MACH_UBNT_RS,
        }, {
index 7f61c14..575d181 100644 (file)
@@ -139,6 +139,7 @@ enum ar71xx_mach_type {
        AR71XX_MACH_TEW_632BRP, /* TRENDnet TEW-632BRP */
        AR71XX_MACH_TL_WR741ND, /* TP-LINK TL-WR741ND */
        AR71XX_MACH_TL_WR941ND, /* TP-LINK TL-WR941ND */
+       AR71XX_MACH_TL_WR1043ND,/* TP-LINK TL-WR1041ND */
        AR71XX_MACH_UBNT_LSSR71, /* Ubiquiti LS-SR71 */
        AR71XX_MACH_UBNT_LSX,   /* Ubiquiti LSX */
        AR71XX_MACH_UBNT_RS,    /* Ubiquiti RouterStation */
index da2f8fd..6a04bf2 100644 (file)
@@ -474,6 +474,10 @@ define Image/Build/Profile/TLWR941NDV2
        $(call Image/Build/Template/TPLINK/$(1),tl-wr941ndv2,board=TL-WR941ND,TL-WR941NDv2)
 endef
 
+define Image/Build/Profile/TLWR1043NDV1
+       $(call Image/Build/Template/TPLINK/$(1),tl-wr1043ndv1,board=TL-WR1043ND,TL-WR1043NDv1)
+endef
+
 define Image/Build/Profile/WNDR3700
        $(call Image/Build/Template/WNDR3700/$(1),wndr3700,board=WNDR3700)
 endef
@@ -503,6 +507,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR841NDV3,$(1))
        $(call Image/Build/Profile/TLWR841NDV5,$(1))
        $(call Image/Build/Profile/TLWR941NDV2,$(1))
+       $(call Image/Build/Profile/TLWR1043NDV1,$(1))
        $(call Image/Build/Profile/UBNT,$(1))
        $(call Image/Build/Profile/WP543,$(1))
        $(call Image/Build/Profile/WNDR3700,$(1))
index ab5ed54..d62ab8a 100644 (file)
@@ -47,3 +47,14 @@ define Profile/TLWR941NDV2/Description
 endef
 
 $(eval $(call Profile,TLWR941NDV2))
+
+define Profile/TLWR1043NDV1
+       NAME:=TP-LINK TL-WR1043ND v1
+       PACKAGES:=kmod-ath9k hostapd-mini
+endef
+
+define Profile/TLWR1043NDV1/Description
+       Package set optimized for the TP-LINK TL-WR1043ND v1.
+endef
+
+$(eval $(call Profile,TLWR1043NDV1))
index cb6a59b..08f345e 100644 (file)
@@ -37,6 +37,7 @@
 #define HWID_TL_WR841ND_V3     0x08410003
 #define HWID_TL_WR841ND_V5     0x08410005
 #define HWID_TL_WR941ND_V2     0x09410002
+#define HWID_TL_WR1043ND_V1    0x10430001
 
 #define MD5SUM_LEN     16
 
@@ -137,6 +138,14 @@ static struct board_info boards[] = {
                .kernel_ep      = 0x80060000,
                .rootfs_ofs     = 0x140000,
        }, {
+               .id             = "TL-WR1043NDv1",
+               .hw_id          = HWID_TL_WR1043ND_V1,
+               .hw_rev         = 1,
+               .fw_max_len     = 0x7c0000,
+               .kernel_la      = 0x80060000,
+               .kernel_ep      = 0x80060000,
+               .rootfs_ofs     = 0x140000,
+       }, {
                /* terminating entry */
        }
 };