kernel: add kmod-video-gspca-konica and remove kmod-video-konica
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 May 2012 20:34:00 +0000 (20:34 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 May 2012 20:34:00 +0000 (20:34 +0000)
kmod-video-konica was removed from kernel 2.6.38 and is now replaced by kmod-video-gspca-konica

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31628 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/video.mk

index 65eeb42..d5e5247 100644 (file)
@@ -65,23 +65,6 @@ endef
 $(eval $(call KernelPackage,video-cpia2))
 
 
-define KernelPackage/video-konica
-  TITLE:=Konica USB webcam support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core
-  KCONFIG:=CONFIG_USB_KONICAWC
-  FILES:=$(LINUX_DIR)/drivers/media/video/usbvideo/konicawc.ko
-  AUTOLOAD:=$(call AutoLoad,70,konicawc)
-  $(call AddDepends/video)
-endef
-
-define KernelPackage/video-konica/description
- Kernel support for webcams based on a Konica chipset. This is known to 
- work with the Intel YC76 webcam.
-endef
-
-$(eval $(call KernelPackage,video-konica))
-
-
 define KernelPackage/video-sn9c102
   TITLE:=SN9C102 Camera Chip support
   DEPENDS:=@USB_SUPPORT +kmod-usb-core
@@ -625,3 +608,18 @@ define KernelPackage/video-gspca-jeilinj/description
 endef
 
 $(eval $(call KernelPackage,video-gspca-jeilinj))
+
+
+define KernelPackage/video-gspca-konica
+  TITLE:=konica webcam support
+  KCONFIG:=CONFIG_USB_GSPCA_KONICA
+  FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_konica.ko
+  AUTOLOAD:=$(call AutoLoad,75,gspca_konica)
+  $(call AddDepends/video-gspca)
+endef
+
+define KernelPackage/video-gspca-konica/description
+ The Konica USB Camera Driver (konica) kernel module.
+endef
+
+$(eval $(call KernelPackage,video-gspca-konica))