opkg: work around unconditional libopenssl build dependency
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Sep 2015 16:31:01 +0000 (16:31 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 11 Sep 2015 16:31:01 +0000 (16:31 +0000)
As the OpenWrt build system only resolves build dependencies per directory,
all opkg variants were causing libopenssl to be downloaded and built,
not only opkg-smime. Fix this by applying the same workaround as in
ustream-ssl.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46850 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/system/opkg/Makefile

index 32bcf2b..4da4d46 100644 (file)
@@ -72,7 +72,7 @@ endef
 define Package/opkg-smime
   $(call Package/opkg/Default)
   TITLE+= (with S/MIME signature support)
-  DEPENDS+=+libopenssl
+  DEPENDS+=+PACKAGE_opkg-smime:libopenssl
   VARIANT:=smime
 endef