[package]
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Mar 2009 19:13:15 +0000 (19:13 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Mar 2009 19:13:15 +0000 (19:13 +0000)
- fix mac assignment for broadcom vifs in bridging mode - thanks abramoff1 for spotting this
- fix possible regression with different interface protocols
- bump PKG_RELEASE

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15042 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/lib/network/config.sh
package/base-files/files/sbin/wifi

index 57d53ec..b148bdf 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=16
+PKG_RELEASE:=17
 
 PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index 29b7fe5..0ab46c1 100755 (executable)
@@ -83,6 +83,7 @@ sort_list() {
 prepare_interface() {
        local iface="$1"
        local config="$2"
+       local vifmac="$3"
 
        # if we're called for the bridge interface itself, don't bother trying
        # to create any interfaces here. The scripts have already done that, otherwise
@@ -93,6 +94,12 @@ prepare_interface() {
                # make sure the interface is removed from any existing bridge and deconfigured 
                ifconfig "$iface" 0.0.0.0
                unbridge "$iface"
+
+               # Change interface MAC address if requested
+               [ -n "$vifmac" ] && {
+                       ifconfig "$iface" down
+                       ifconfig "$iface" hw ether "$vifmac" up
+               }
        }
 
        # Setup VLAN interfaces
@@ -209,6 +216,7 @@ setup_interface_alias() {
 setup_interface() {
        local iface="$1"
        local config="$2"
+       local vifmac="$4"
        local proto
        local macaddr
 
@@ -218,7 +226,7 @@ setup_interface() {
        }
        proto="${3:-$(config_get "$config" proto)}"
        
-       prepare_interface "$iface" "$config" || return 0
+       prepare_interface "$iface" "$config" "$vifmac" || return 0
        
        [ "$iface" = "br-$config" ] && {
                # need to bring up the bridge and wait a second for 
@@ -231,7 +239,6 @@ setup_interface() {
        # Interface settings
        config_get mtu "$config" mtu
        config_get macaddr "$config" macaddr
-       macaddr="${macaddr:-$3}"
        grep "$iface:" /proc/net/dev > /dev/null && \
                $DEBUG ifconfig "$iface" down && \
                $DEBUG ifconfig "$iface" ${macaddr:+hw ether "$macaddr"} ${mtu:+mtu $mtu} up
index 30ecb1b..e0aca63 100755 (executable)
@@ -66,11 +66,12 @@ wifi_detect() {
 start_net() {(
        local iface="$1"
        local config="$2"
+       local vifmac="$3"
 
        [ -f "/var/run/$iface.pid" ] && kill "$(cat /var/run/${iface}.pid)" 2>/dev/null
        include /lib/network
        scan_interfaces
-       setup_interface "$1" "$2" "$3"
+       setup_interface "$iface" "$config" "" "$vifmac"
 )}
 
 set_wifi_up() {