image: fix initramfs image name
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 19 Jul 2013 17:12:45 +0000 (17:12 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 19 Jul 2013 17:12:45 +0000 (17:12 +0000)
Preserve order of components in initramfs image filename
when doing copy from $(KDIR) to $(BIN_DIR).

Patchwork: http://patchwork.openwrt.org/patch/3811/
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37452 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 7d63a18..80be17a 100644 (file)
@@ -69,7 +69,7 @@ endef
 
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
   define Image/BuildKernel/Initramfs
-       cp $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-initramfs-vmlinux.elf
+       cp $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.elf
        $(call Image/Build/Initramfs)
   endef
 else