[kernel]: bundle ehci-orion with kmod-usb2
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Jun 2014 15:02:28 +0000 (15:02 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Jun 2014 15:02:28 +0000 (15:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41230 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/usb.mk

index 47e3372..9aa3e8c 100644 (file)
@@ -394,6 +394,9 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.8.0)),1)
   FILES:= \
        $(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko \
        $(LINUX_DIR)/drivers/usb/host/ehci-platform.ko
+  ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
+    FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-orion.ko
+  endif
   AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform,1)
 else
   FILES:=$(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko