ar71xx: create a profile and build images for Compex WPE72
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Jan 2012 17:01:44 +0000 (17:01 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Jan 2012 17:01:44 +0000 (17:01 +0000)
[juhosg: remove ath9k from the the profile package list, build WPE72
image with the Default profile as well]

Signed-off-by: Johnathan Boyce <jon.boyce@globalreach.eu.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29914 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/generic/profiles/compex.mk
target/linux/ar71xx/image/Makefile

index 38d963a..3491473 100644 (file)
@@ -15,3 +15,14 @@ define Profile/WP543/Description
 endef
 
 $(eval $(call Profile,WP543))
+
+define Profile/WPE72
+       NAME:=Compex WPE72/WPE72NX
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/WPE72/Description
+       Package set optimized for the Compex WPE72 boards including Compex WPE72NX Indoor Access Point.
+endef
+
+$(eval $(call Profile,WPE72))
index a567286..4e538b8 100644 (file)
@@ -684,6 +684,11 @@ define Image/Build/Profile/WP543
        $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wp543,$(wp543_cmdline),0x1000000,16M)
 endef
 
+wpe72_cmdline=console=ttyS0,115200
+define Image/Build/Profile/WPE72
+       $(call Image/Build/Template/$(fs_64k)/$(1),MyLoader,wpe72,$(wpe72_cmdline),0x800000,8M)
+endef
+
 dir600a1_cmdline=board=DIR-600-A1 console=ttyS0,115200
 define Image/Build/Profile/DIR600A1
        $(call Image/Build/Template/$(fs_64k)/$(1),Cameo7240,dir-600-a1,$(dir600a1_cmdline),"AP91-AR7240-RT-090223-00")
@@ -1011,6 +1016,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR2543,$(1))
        $(call Image/Build/Profile/UBNT,$(1))
        $(call Image/Build/Profile/WP543,$(1))
+       $(call Image/Build/Profile/WPE72,$(1))
        $(call Image/Build/Profile/WNDR3700,$(1))
        $(call Image/Build/Profile/AP96,$(1))
        $(call Image/Build/Profile/WRT400N,$(1))