ramips: fix build error on oversized images by putting the dir-860l-b1 size check...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Feb 2016 19:18:21 +0000 (19:18 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Feb 2016 19:18:21 +0000 (19:18 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48681 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/image/Makefile

index c109e6a..27f349f 100644 (file)
@@ -1034,8 +1034,8 @@ define Device/dir-860l-b1
   IMAGE/factory.bin := \
        append-kernel | pad-offset 65536 64 | append-rootfs | pad-rootfs -x 64 | \
        seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
-       check-size $$$$(IMAGE_SIZE) | \
-       seama-seal -m "signature=wrgac13_dlink.2013gui_dir860lb"
+       seama-seal -m "signature=wrgac13_dlink.2013gui_dir860lb" | \
+       check-size $$$$(IMAGE_SIZE)
 endef
 
 define Device/firewrt