Revert "6in4: Corrected tunnelbroker tunnel update URL"
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Jan 2016 23:25:38 +0000 (23:25 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Jan 2016 23:25:38 +0000 (23:25 +0000)
The auth change appears to break the endpoint update for most users and with
my local tests the old update url works just fine.

This reverts commit 99c03a88cb6fed0519efdfaac305794653a12542.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48384 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/6in4/Makefile
package/network/ipv6/6in4/files/6in4.sh

index b51b12d..9eca57a 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=23
+PKG_VERSION:=22
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
index 05471db..59747a3 100755 (executable)
@@ -108,7 +108,7 @@ proto_6in4_setup() {
                        fi
                }
 
-               local url="$http://$username:$password@ipv4.tunnelbroker.net/nic/update?hostname=$tunnelid"
+               local url="$http://ipv4.tunnelbroker.net/nic/update?username=$username&password=$password&hostname=$tunnelid"
                local try=0
                local max=3