fix prepare error with brcm-2.4 and missing files/ (thx, thepeople)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 Oct 2008 19:26:36 +0000 (19:26 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 Oct 2008 19:26:36 +0000 (19:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13021 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/quilt.mk

index c569231..d3233d8 100644 (file)
@@ -66,9 +66,10 @@ define Build/Patch/Default
        $(call PatchDir,$(PATCH_DIR),)
 endef
 
+kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
 define Kernel/Patch/Default
        rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches
-       $(CP) $(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.) $(LINUX_DIR)/
+       $(if $(kernel_files),$(CP) $(kernel_files) $(LINUX_DIR)/)
        find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
        $(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
        $(call PatchDir,$(PATCH_DIR),platform/)