brcm63xx: package the USB gadget module (bcm63xx_udc)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 14 Jan 2014 05:23:20 +0000 (05:23 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 14 Jan 2014 05:23:20 +0000 (05:23 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39281 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/modules.mk

index 88fa4b4..48a2bf8 100644 (file)
@@ -19,3 +19,19 @@ define KernelPackage/pcmcia-bcm63xx/description
 endef
 
 $(eval $(call KernelPackage,pcmcia-bcm63xx))
+
+define KernelPackage/bcm63xx-udc
+  SUBMENU:=$(USB_MENU)
+  TITLE:=Broadcom BCM63xx UDC support
+  DEPENDS:=@TARGET_brcm63xx +kmod-usb-gadget
+  KCONFIG:=CONFIG_USB_BCM63XX_UDC
+  FILES:=$(LINUX_DIR)/drivers/usb/gadget/bcm63xx_udc.ko
+  AUTOLOAD:=$(call AutoLoad,51,bcm63xx_udc)
+  $(call AddDepends/usb)
+endef
+
+define KernelPackage/bcm63xx-udc/description
+  Kernel support for the USB gadget (device) controller on the BCM63xx SoC
+endef
+
+$(eval $(call KernelPackage,bcm63xx-udc))