build: include homebrew include/library directory in cflags/ldflags on mac os x
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Oct 2015 14:11:30 +0000 (14:11 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Oct 2015 14:11:30 +0000 (14:11 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47139 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host-build.mk

index 760d38b..e2b5f2f 100644 (file)
@@ -50,6 +50,11 @@ define Host/Prepare
   $(call Host/Prepare/Default)
 endef
 
+ifeq ($(HOST_OS),Darwin)
+  HOST_CFLAGS += -I/usr/local/opt/openssl/include
+  HOST_LDFLAGS += -L/usr/local/opt/openssl/lib
+endif
+
 HOST_CONFIGURE_VARS = \
        CC="$(HOSTCC)" \
        CFLAGS="$(HOST_CFLAGS)" \