linux: add missing dependencies to kmod-fs-msdos and kmod-fs-xfs
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Jul 2013 13:57:36 +0000 (13:57 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Jul 2013 13:57:36 +0000 (13:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37398 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/fs.mk

index 536e28b..70387fd 100644 (file)
@@ -203,6 +203,7 @@ $(eval $(call KernelPackage,fs-minix))
 define KernelPackage/fs-msdos
   SUBMENU:=$(FS_MENU)
   TITLE:=MSDOS filesystem support
+  DEPENDS:=+kmod-fs-vfat
   KCONFIG:=CONFIG_MSDOS_FS
   FILES:=$(LINUX_DIR)/fs/fat/msdos.ko
   AUTOLOAD:=$(call AutoLoad,40,msdos)
@@ -360,7 +361,7 @@ define KernelPackage/fs-xfs
   SUBMENU:=$(FS_MENU)
   TITLE:=XFS filesystem support
   KCONFIG:=CONFIG_XFS_FS
-  DEPENDS:= +kmod-fs-exportfs @!avr32
+  DEPENDS:= +kmod-fs-exportfs +kmod-lib-crc32c @!avr32
   FILES:=$(LINUX_DIR)/fs/xfs/xfs.ko
   AUTOLOAD:=$(call AutoLoad,30,xfs,1)
 endef