sync with buildroot2 from uclibc, add two variables PACKAGE_DIR and PATCH, remove...
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Feb 2005 07:43:13 +0000 (07:43 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 19 Feb 2005 07:43:13 +0000 (07:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@265 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Config.in
package/Makefile.in

index f7eff06..f22f83e 100644 (file)
@@ -2,15 +2,17 @@
 
 menu "OpenWrt Package Selection"
 
-comment "The default set"
+comment "The absolute minimum"
+source "package/linux/Config.in"
 source "package/busybox/Config.in"
+
+comment "The default set"
 source "package/dnsmasq/Config.in"
-source "package/linux/Config.in"
 source "package/iptables/Config.in"
 source "package/bridge/Config.in"
 
 comment "Suggested Extras"
-source "package/dropbear_sshd/Config.in"
 source "package/ebtables/Config.in"
+source "package/dropbear_sshd/Config.in"
 
 endmenu
index e8ec23e..0d600d0 100644 (file)
@@ -1,5 +1,3 @@
-LINKSYS_TGZ_SITE=http://openwrt.openbsd-geek.de
-
 MAKE1=make
 MAKE=make -j$(BR2_JLEVEL)
 
@@ -17,8 +15,8 @@ TARGET_CFLAGS=$(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING)
 HOSTCC:=gcc
 BASE_DIR:=${shell pwd}
 DL_DIR:=$(BASE_DIR)/dl
-#PATCH_DIR=$(BASE_DIR)/sources/patches
 BUILD_DIR:=$(BASE_DIR)/build_$(ARCH)$(ARCH_FPU_SUFFIX)
+PACKAGE_DIR:=$(BASE_DIR)/package
 TARGET_DIR:=$(BUILD_DIR)/root
 TOOL_BUILD_DIR=$(BASE_DIR)/toolchain_build_$(ARCH)$(ARCH_FPU_SUFFIX)
 # Strip off the annoying quoting
@@ -32,6 +30,7 @@ KERNEL_CROSS=$(STAGING_DIR)/bin/$(OPTIMIZE_FOR_CPU)-linux-uclibc-
 TARGET_CROSS=$(STAGING_DIR)/bin/$(OPTIMIZE_FOR_CPU)-linux-uclibc-
 TARGET_CC=$(TARGET_CROSS)gcc
 STRIP=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
+PATCH=toolchain/patch-kernel.sh
 
 
 HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \