busybox: rename ntp init script back to sysntpd (#13920)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Aug 2013 12:40:24 +0000 (12:40 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Aug 2013 12:40:24 +0000 (12:40 +0000)
Renaming the init script to ntp broke LuCI time sync functionality and collides with other ntp packages

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37681 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/utils/busybox/Makefile
package/utils/busybox/files/ntp [deleted file]
package/utils/busybox/files/sysntpd [new file with mode: 0755]

index 0b2778f..15f96eb 100644 (file)
@@ -37,7 +37,7 @@ endif
 
 init-y :=
 init-$(CONFIG_BUSYBOX_CONFIG_CROND) += cron
 
 init-y :=
 init-$(CONFIG_BUSYBOX_CONFIG_CROND) += cron
-init-$(CONFIG_BUSYBOX_CONFIG_NTPD) += ntp
+init-$(CONFIG_BUSYBOX_CONFIG_NTPD) += sysntpd
 init-$(CONFIG_BUSYBOX_CONFIG_TELNETD) += telnet
 
 define Package/busybox
 init-$(CONFIG_BUSYBOX_CONFIG_TELNETD) += telnet
 
 define Package/busybox
diff --git a/package/utils/busybox/files/ntp b/package/utils/busybox/files/ntp
deleted file mode 100755 (executable)
index c40ee76..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2011 OpenWrt.org
-
-START=98
-
-USE_PROCD=1
-PROG=/usr/sbin/ntpd
-SERVICE_PID_FILE=/var/run/sysntpd.pid
-
-start_service() {
-       local peers
-       local args="-n"
-       local enable_server
-
-       config_load system
-       config_get peers ntp server
-       config_get_bool enable_server ntp enable_server 0
-
-       [ $enable_server -eq 0 -a -z "$peers" ] && return
-
-       procd_open_instance
-       procd_set_param command "$PROG" -n
-        [ $enable_server -ne 0 ] && procd_append_param command -l
-       [ -n "$peers" ] && {
-               local peer
-               for peer in $peers; do
-                       procd_append_param command -p $peer
-               done
-       }
-       procd_close_instance
-}
diff --git a/package/utils/busybox/files/sysntpd b/package/utils/busybox/files/sysntpd
new file mode 100755 (executable)
index 0000000..c40ee76
--- /dev/null
@@ -0,0 +1,31 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2011 OpenWrt.org
+
+START=98
+
+USE_PROCD=1
+PROG=/usr/sbin/ntpd
+SERVICE_PID_FILE=/var/run/sysntpd.pid
+
+start_service() {
+       local peers
+       local args="-n"
+       local enable_server
+
+       config_load system
+       config_get peers ntp server
+       config_get_bool enable_server ntp enable_server 0
+
+       [ $enable_server -eq 0 -a -z "$peers" ] && return
+
+       procd_open_instance
+       procd_set_param command "$PROG" -n
+        [ $enable_server -ne 0 ] && procd_append_param command -l
+       [ -n "$peers" ] && {
+               local peer
+               for peer in $peers; do
+                       procd_append_param command -p $peer
+               done
+       }
+       procd_close_instance
+}