mvebu: fix WRT1900AC v1 LED driver module
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Feb 2016 12:33:53 +0000 (12:33 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Feb 2016 12:33:53 +0000 (12:33 +0000)
Update OpenWRT build tree to reflect changes in TLC-591xx LED family driver.

In kernels < 4.0 the driver was present in form of a patch for the TLC-59116 chip,
and was upstreamed later in kernels > 4.0 to support the entire chip family.

Signed-off-by: Sebastian Careba <nitroshift@yahoo.com>
[jow: fix Kconfig symbol name]
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48684 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/leds.mk
target/linux/mvebu/profiles/linksys.mk

index 996deb3..c4261d3 100644 (file)
@@ -199,17 +199,17 @@ endef
 $(eval $(call KernelPackage,leds-pca963x))
 
 
-define KernelPackage/leds-tlc59116
+define KernelPackage/leds-tlc591xx
   SUBMENU:=$(LEDS_MENU)
-  TITLE:=TLC59116 LED support
+  TITLE:=TLC591xx LED support
   DEPENDS:=@TARGET_mvebu +kmod-i2c-core +kmod-regmap
-  KCONFIG:=CONFIG_LEDS_TLC59116
-  FILES:=$(LINUX_DIR)/drivers/leds/leds-tlc59116.ko
-  AUTOLOAD:=$(call AutoLoad,60,leds-tlc59116,1)
+  KCONFIG:=CONFIG_LEDS_TLC591XX
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-tlc591xx.ko
+  AUTOLOAD:=$(call AutoLoad,60,leds-tlc591xx,1)
 endef
 
-define KernelPackage/leds-tlc59116/description
- Kernel module for LEDs on TLC59116
+define KernelPackage/leds-tlc591xx/description
+ Kernel module for LEDs on TLC591xx
 endef
 
-$(eval $(call KernelPackage,leds-tlc59116))
+$(eval $(call KernelPackage,leds-tlc591xx))
index 1a5b8af..9c954bd 100644 (file)
@@ -53,7 +53,7 @@ define Profile/Mamba
        kmod-ata-core kmod-ata-marvell-sata \
        kmod-rtc-marvell kmod-thermal-armada \
        kmod-gpio-button-hotplug kmod-hwmon-tmp421 \
-       kmod-hwmon-pwmfan kmod-leds-tlc59116 \
+       kmod-hwmon-pwmfan kmod-leds-tlc591xx \
        kmod-ledtrig-usbdev kmod-mwlwifi wpad-mini \
        swconfig
 endef