kernel: reduce spurious rebuilds of simple kmod-* packages
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Jul 2013 16:32:07 +0000 (16:32 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Jul 2013 16:32:07 +0000 (16:32 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37403 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/Makefile

index 4ca442f..e10e99c 100644 (file)
@@ -18,6 +18,9 @@ PKG_LICENSE:=GPLv2
 PKG_LICENSE_FILES:=
 
 include $(INCLUDE_DIR)/package.mk
+
+STAMP_BUILT:=$(STAMP_BUILT)_$(firstword $(shell $(SCRIPT_DIR)/kconfig.pl $(LINUX_DIR)/.config | md5sum))
+
 ifeq ($(DUMP),)
   -include $(LINUX_DIR)/.config
 endif
@@ -32,6 +35,9 @@ endef
 define Build/Compile
 endef
 
+define KernelPackage/depends
+endef
+
 CONFIG_PACKAGE_kernel=y
 define Package/kernel
   SECTION:=sys