sync dropbear init script with whiterussian, fix locking and add config integration...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Oct 2006 05:53:13 +0000 (05:53 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Oct 2006 05:53:13 +0000 (05:53 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5331 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/dropbear/Makefile
package/dropbear/files/dropbear.config [new file with mode: 0644]
package/dropbear/files/dropbear.init

index 18e4a45..546facf 100644 (file)
@@ -106,6 +106,8 @@ define Package/dropbear/install
        ln -sf ../sbin/dropbear $(1)/usr/bin/ssh
        ln -sf ../sbin/dropbear $(1)/usr/bin/dbclient
        ln -sf ../sbin/dropbear $(1)/usr/bin/dropbearkey
+       install -d -m0755 $(1)/etc/config
+       install -m0755 ./files/dropbear.config $(1)/etc/config/dropbear
        install -d -m0755 $(1)/etc/init.d
        install -m0755 ./files/dropbear.init $(1)/etc/init.d/dropbear
 endef
diff --git a/package/dropbear/files/dropbear.config b/package/dropbear/files/dropbear.config
new file mode 100644 (file)
index 0000000..e660ac7
--- /dev/null
@@ -0,0 +1,3 @@
+config dropbear
+       option PasswordAuth 'on'
+       option Port         '22'
index b928af6..6f35672 100755 (executable)
@@ -1,21 +1,49 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006 Carlos Sobrinho
+
+config_cb() {
+       local cfg="$CONFIG_SECTION"
+       local nopasswd
+       local type
+       config_get cfgtype "$cfg" TYPE
+
+       case "$cfgtype" in
+               dropbear)
+                       config_get passauth $cfg PasswordAuth
+                       config_get port $cfg Port
+
+                       case "$passauth" in
+                               no|off|disabled|0) nopasswd=1;;
+                       esac
+                       DROPBEAR_ARGS="${port:+-p $port} ${nopasswd:+-s}"
+               ;;
+       esac
+}
 
 start() {
-       for type in rsa dss; do {
-         # check for keys
-         key=/etc/dropbear/dropbear_${type}_host_key
-         [ ! -f $key ] && {
-           # generate missing keys
-           mkdir -p /etc/dropbear
-           [ -x /usr/bin/dropbearkey ] && {
-             /usr/bin/dropbearkey -t $type -f $key 2>&- >&- && exec /etc/rc.common "$initscript" start
-           } &
-           exit 0
-         }
-       }; done
+       for keytype in rsa dss; do
+               # check for keys
+               key=/tmp/dropbear/dropbear_${keytype}_host_key
+               [ ! -f $key ] && {
+                       # generate missing keys
+                       mkdir -p /tmp/dropbear
+                       [ -x /usr/bin/dropbearkey ] && {
+                               /usr/bin/dropbearkey -t $keytype -f $key 2>&- >&- && exec /etc/rc.common "$initscript" start
+                       } &
+               exit 0
+               }
+       done
+
+       lock /tmp/.switch2jffs
+       mkdir -p /etc/dropbear
+       mv /tmp/dropbear/dropbear_* /etc/dropbear/
+       lock -u /tmp/.switch2jffs
        
-       /usr/sbin/dropbear
+       chown root /etc/dropbear
+       chmod 0700 /etc/dropbear
+       config_load dropbear
+       /usr/sbin/dropbear $DROPBEAR_ARGS
 }
 
 stop() {