kernel: disable MIPS VDSO by default until the cache issues have been resolved
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 26 Feb 2016 09:49:32 +0000 (09:49 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 26 Feb 2016 09:49:32 +0000 (09:49 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48802 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/generic/patches-4.4/206-mips-disable-vdso.patch [new file with mode: 0644]

diff --git a/target/linux/generic/patches-4.4/206-mips-disable-vdso.patch b/target/linux/generic/patches-4.4/206-mips-disable-vdso.patch
new file mode 100644 (file)
index 0000000..9b1346d
--- /dev/null
@@ -0,0 +1,21 @@
+Disable MIPS VDSO until the cache issues have been sorted out.
+
+Signed-off-by: Felix Fietkau <nbd@openwrt.org>
+
+--- a/arch/mips/vdso/Makefile
++++ b/arch/mips/vdso/Makefile
+@@ -26,11 +26,11 @@ aflags-vdso := $(ccflags-vdso) \
+ # the comments on that file.
+ #
+ ifndef CONFIG_CPU_MIPSR6
+-  ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
+-    $(warning MIPS VDSO requires binutils >= 2.25)
++#  ifeq ($(call ld-ifversion, -lt, 22500000, y),y)
++#    $(warning MIPS VDSO requires binutils >= 2.25)
+     obj-vdso-y := $(filter-out gettimeofday.o, $(obj-vdso-y))
+     ccflags-vdso += -DDISABLE_MIPS_VDSO
+-  endif
++#  endif
+ endif
+ # VDSO linker flags.