package/kernel: enable CONFIG_SND_SOC_DMAENGINE_PCM in sound-soc-core
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Dec 2012 21:05:32 +0000 (21:05 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Dec 2012 21:05:32 +0000 (21:05 +0000)
This is required for 3.6+ kernels and some sound SoC modules.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34618 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/sound.mk

index 6f83701..f80fa36 100644 (file)
@@ -149,6 +149,7 @@ define KernelPackage/sound-soc-core
   DEPENDS:=+kmod-regmap
   KCONFIG:= \
        CONFIG_SND_SOC \
+       CONFIG_SND_SOC_DMAENGINE_PCM=y \
        CONFIG_SND_SOC_ALL_CODECS=n
   FILES:=$(LINUX_DIR)/sound/soc/snd-soc-core.ko
   AUTOLOAD:=$(call AutoLoad,55, snd-soc-core)