ar71xx: image: add mtdpartsize macro
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 Sep 2013 09:11:25 +0000 (09:11 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 Sep 2013 09:11:25 +0000 (09:11 +0000)
The new macro will be used to determine the firmware
partition size from an MTD layout.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38117 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index 60990b2..8ac7044 100644 (file)
@@ -31,6 +31,10 @@ define mkcmdline
 $(if $(1),board=$(1) )$(if $(2),console=$(2)$(COMMA)$(3))
 endef
 
+define mtdpartsize
+$(shell echo $$((`echo '$(2)' | sed -e 's/.*[:$(COMMA)]\([0-9]*\)k[@]*[0-9a-zx]*($(1)).*/\1/'` * 1024)))
+endef
+
 SINGLE_PROFILES:=
 
 define SingleProfile