ralink: make cevt systick selectable via kconfig
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Oct 2013 15:02:23 +0000 (15:02 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Oct 2013 15:02:23 +0000 (15:02 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38319 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/mt7620a/config-3.10
target/linux/ramips/patches-3.10/0011-MIPS-ralink-add-support-for-systick-timer-found-on-n.patch
target/linux/ramips/rt305x/config-3.10

index 47ed648..7699398 100644 (file)
@@ -9,7 +9,7 @@ CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
 CONFIG_CC_OPTIMIZE_FOR_SIZE=y
 CONFIG_CEVT_R4K=y
 CONFIG_CLKDEV_LOOKUP=y
-CONFIG_CLKEVT_RT3352=y
+# CONFIG_CLKEVT_RT3352 is not set
 CONFIG_CLKSRC_MMIO=y
 CONFIG_CLKSRC_OF=y
 CONFIG_CLONE_BACKWARDS=y
index 6d4911b..a69739b 100644 (file)
@@ -16,13 +16,15 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  3 files changed, 154 insertions(+)
  create mode 100644 arch/mips/ralink/cevt-rt3352.c
 
---- a/arch/mips/ralink/Kconfig
-+++ b/arch/mips/ralink/Kconfig
+Index: linux-3.10.13/arch/mips/ralink/Kconfig
+===================================================================
+--- linux-3.10.13.orig/arch/mips/ralink/Kconfig        2013-09-27 02:18:49.000000000 +0200
++++ linux-3.10.13/arch/mips/ralink/Kconfig     2013-10-02 21:40:41.252368892 +0200
 @@ -1,5 +1,12 @@
  if RALINK
  
 +config CLKEVT_RT3352
-+      bool
++      bool "Systick Clockevent source"
 +      depends on SOC_RT305X || SOC_MT7620
 +      default y
 +      select CLKSRC_OF
@@ -31,8 +33,10 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  choice
        prompt "Ralink SoC selection"
        default SOC_RT305X
---- a/arch/mips/ralink/Makefile
-+++ b/arch/mips/ralink/Makefile
+Index: linux-3.10.13/arch/mips/ralink/Makefile
+===================================================================
+--- linux-3.10.13.orig/arch/mips/ralink/Makefile       2013-10-02 20:46:43.856230578 +0200
++++ linux-3.10.13/arch/mips/ralink/Makefile    2013-10-02 21:13:11.584298451 +0200
 @@ -8,6 +8,8 @@
  
  obj-y := prom.o of.o reset.o clk.o irq.o timer.o
@@ -42,8 +46,10 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  obj-$(CONFIG_SOC_RT288X) += rt288x.o
  obj-$(CONFIG_SOC_RT305X) += rt305x.o
  obj-$(CONFIG_SOC_RT3883) += rt3883.o
---- /dev/null
-+++ b/arch/mips/ralink/cevt-rt3352.c
+Index: linux-3.10.13/arch/mips/ralink/cevt-rt3352.c
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ linux-3.10.13/arch/mips/ralink/cevt-rt3352.c       2013-10-02 21:13:19.396298787 +0200
 @@ -0,0 +1,145 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
index 78902d5..e177294 100644 (file)
@@ -9,7 +9,7 @@ CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
 CONFIG_CC_OPTIMIZE_FOR_SIZE=y
 CONFIG_CEVT_R4K=y
 CONFIG_CLKDEV_LOOKUP=y
-CONFIG_CLKEVT_RT3352=y
+# CONFIG_CLKEVT_RT3352 is not set
 CONFIG_CLKSRC_MMIO=y
 CONFIG_CLKSRC_OF=y
 CONFIG_CLONE_BACKWARDS=y