brcm2708: add DT support
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 14 Jul 2015 07:37:29 +0000 (07:37 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 14 Jul 2015 07:37:29 +0000 (07:37 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46344 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm2708/bcm2708/config-default
target/linux/brcm2708/bcm2709/config-default
target/linux/brcm2708/config-3.18
target/linux/brcm2708/image/Makefile
target/linux/brcm2708/image/config.txt

index 858d236..2fdc4e9 100644 (file)
@@ -1,4 +1,4 @@
 CONFIG_ARCH_BCM2708=y
-# CONFIG_BCM2708_DT is not set
+CONFIG_BCM2708_DT=y
 CONFIG_MACH_BCM2708=y
 CONFIG_VMSPLIT_3G=y
index 8945c24..9fddfe4 100644 (file)
@@ -3,7 +3,7 @@ CONFIG_ARCH_BCM2709=y
 # CONFIG_ARM_THUMBEE is not set
 CONFIG_ARM_ARCH_TIMER_EVTSTREAM=y
 CONFIG_BCM2708_NOL2CACHE=y
-# CONFIG_BCM2709_DT is not set
+CONFIG_BCM2709_DT=y
 # CONFIG_CRYPTO_SHA1_ARM_NEON is not set
 # CONFIG_CRYPTO_SHA512_ARM_NEON is not set
 CONFIG_HAVE_ARM_ARCH_TIMER=y
index e788bb8..33007dd 100644 (file)
@@ -203,6 +203,8 @@ CONFIG_NLS_ASCII=y
 CONFIG_NLS_DEFAULT="utf8"
 CONFIG_NO_HZ=y
 CONFIG_OABI_COMPAT=y
+CONFIG_OF=y
+CONFIG_OF_GPIO=y
 CONFIG_PAGEFLAGS_EXTENDED=y
 CONFIG_PAGE_OFFSET=0xC0000000
 # CONFIG_PCI_SYSCALL is not set
@@ -223,10 +225,16 @@ CONFIG_SCSI=y
 # CONFIG_SCSI_LOWLEVEL is not set
 # CONFIG_SCSI_PROC_FS is not set
 # CONFIG_SENSORS_BCM2835 is not set
-# CONFIG_SERIAL_8250 is not set
+CONFIG_SERIAL_8250=y
+# CONFIG_SERIAL_8250_DEPRECATED_OPTIONS is not set
+CONFIG_SERIAL_8250_CONSOLE=y
+# CONFIG_SERIAL_8250_DMA is not set
+CONFIG_SERIAL_8250_NR_UARTS=1
+CONFIG_SERIAL_8250_RUNTIME_UARTS=0
 # CONFIG_SERIAL_AMBA_PL010 is not set
 CONFIG_SERIAL_AMBA_PL011=y
 CONFIG_SERIAL_AMBA_PL011_CONSOLE=y
+CONFIG_SERIAL_OF_PLATFORM=y
 # CONFIG_SND_BCM2708_SOC_I2S is not set
 # CONFIG_SQUASHFS is not set
 # CONFIG_STAGING is not set
@@ -255,6 +263,7 @@ CONFIG_USB_STORAGE=y
 CONFIG_USB_SUPPORT=y
 CONFIG_USB_UAS=y
 CONFIG_USB_USBNET=y
+CONFIG_USE_OF=y
 CONFIG_VECTORS_BASE=0xffff0000
 CONFIG_VFP=y
 # CONFIG_VIDEO_BCM2835 is not set
index e70bdd0..10ecfda 100644 (file)
@@ -11,30 +11,67 @@ include $(INCLUDE_DIR)/host.mk
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
-define Image/Build/RaspberryPi
-       rm -f $(KDIR)/boot.img
-
-       mkfs.fat -C $(KDIR)/boot.img $(FAT32_BLOCKS)
-       # Raspberry Pi has no bootloader, instead the GPU loads and starts the kernel
-       mcopy -i $(KDIR)/boot.img $(KDIR)/bootcode.bin ::
-       mcopy -i $(KDIR)/boot.img $(KDIR)/COPYING.linux ::
-       mcopy -i $(KDIR)/boot.img $(KDIR)/LICENCE.broadcom ::
-       mcopy -i $(KDIR)/boot.img $(KDIR)/start.elf ::
-       mcopy -i $(KDIR)/boot.img $(KDIR)/start_cd.elf ::
-       mcopy -i $(KDIR)/boot.img $(KDIR)/fixup.dat ::
-       mcopy -i $(KDIR)/boot.img $(KDIR)/fixup_cd.dat ::
-       mcopy -i $(KDIR)/boot.img cmdline.txt ::
-       mcopy -i $(KDIR)/boot.img config.txt ::
-       mcopy -i $(KDIR)/boot.img $(KDIR)/Image ::kernel.img  # Copy OpenWrt built kernel
-       ./gen_rpi_sdcard_img.sh $(BIN_DIR)/$(IMG_PREFIX)-sdcard-vfat-$(1).img $(KDIR)/boot.img $(KDIR)/root.$(1) \
+### Image scripts ###
+define Build/build-dtb
+       $(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $@.dtb $(DTS_DIR)/$(DEVICE_DTS).dts
+endef
+
+define Build/gen-cfg
+       cat config.txt > $@.config
+       echo -e "\ndevice_tree=$(DEVICE_DTS).dtb" >> $@.config
+endef
+
+define Build/boot-img
+       rm -f $@.boot
+       mkfs.fat -C $@.boot $(FAT32_BLOCKS)
+       mcopy -i $@.boot $(KDIR)/bootcode.bin ::
+       mcopy -i $@.boot $(KDIR)/COPYING.linux ::
+       mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
+       mcopy -i $@.boot $(KDIR)/start.elf ::
+       mcopy -i $@.boot $(KDIR)/start_cd.elf ::
+       mcopy -i $@.boot $(KDIR)/fixup.dat ::
+       mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
+       mcopy -i $@.boot cmdline.txt ::
+       mcopy -i $@.boot $@.config ::config.txt
+       mcopy -i $@.boot $(word 1,$^) ::kernel.img
+       mcopy -i $@.boot $@.dtb ::$(DEVICE_DTS).dtb
+endef
+
+define Build/sdcard-img
+       ./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
                $(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
 endef
 
-define Image/Build
-       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
-       $(CP) $(KDIR)/Image $(BIN_DIR)/$(IMG_PREFIX)-Image
+### Device macros ###
+define Device/Default
+  FILESYSTEMS := ext4
+  PROFILES = Default $$(DEVICE_PROFILE)
+  KERNEL := kernel-bin
+  IMAGES := sdcard.bin
+  IMAGE/sdcard.bin := build-dtb | gen-cfg | boot-img | sdcard-img
+  DEVICE_PROFILE :=
+  DEVICE_NAME :=
+  DEVICE_DTS :=
+endef
+DEVICE_VARS += DEVICE_PROFILE DEVICE_NAME DEVICE_DTS
 
-       $(call Image/Build/RaspberryPi,$(1))
+# $(1) = profile
+# $(2) = image name
+# $(3) = dts
+define add_bcm2708
+  define Device/$(2)
+    DEVICE_PROFILE := $(1)
+    DEVICE_NAME := $(2)
+    DEVICE_DTS := $(3)
+  endef
+  TARGET_DEVICES += $(2)
 endef
 
+# Raspberry Pi Model B
+$(eval $(call add_bcm2708,RaspberryPi,rpi-b,bcm2708-rpi-b))
+# Raspberry Pi Model B+
+$(eval $(call add_bcm2708,RaspberryPi,rpi-b-plus,bcm2708-rpi-b-plus))
+# Raspberry Pi 2 Model B
+$(eval $(call add_bcm2708,RaspberryPi2,rpi-2-b,bcm2709-rpi-2-b))
+
 $(eval $(call BuildImage))
index f7c46c6..9e6e8e9 100644 (file)
 ##     Stop start.elf from filling in ATAGS (memory from 0x100) before
 ##     launching kernel
 ##
-#disable_commandline_tags=0
+disable_commandline_tags=1
 
 ## cmdline (string)
 ##     Command line parameters. Can be used instead of cmdline.txt file
 ## kernel_address
 ##     Address to load kernel.img file at
 ##
-#kernel_address=0x00000000
+kernel_address=0x8000
 
 ## ramfsfile (string)
 ##     ramfs file to load
 ## device_tree_address
 ##     Address to load device_tree at
 ##
-#device_tree_address=0x00000000
+device_tree_address=0x100
 
 ## init_uart_baud
 ##     Initial uart baud rate.
 ##
 ##     Default 115200
 ##
-#init_uart_baud=115200
+init_uart_baud=115200
 
 ## init_uart_clock
 ##     Initial uart clock.
 ##
 ##     Default 3000000 (3MHz)
 ##
-#init_uart_clock=3000000
+init_uart_clock=3000000
 
 ## init_emmc_clock
 ##     Initial emmc clock, increasing this can speedup your SD-card.
 ##     7        1.375 V
 ##     8        1.4   V
 ##
-#over_voltage_sdram_p=0
\ No newline at end of file
+#over_voltage_sdram_p=0