some Makefile cleanup
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Feb 2005 02:35:19 +0000 (02:35 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Feb 2005 02:35:19 +0000 (02:35 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@230 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/squashfs/Makefile.in
target/squashfs/squashfsroot.mk

index f789617..a5f875a 100644 (file)
@@ -1,3 +1,3 @@
 ifeq ($(strip $(BR2_TARGET_ROOTFS_SQUASHFS)),y)
-TARGETS+=squashfsroot openwrt-code.bin.squashfs
+TARGETS+=openwrt-image
 endif
index f3d2808..f97b641 100644 (file)
@@ -4,6 +4,8 @@
 # 
 #############################################################
 
+ROOTFSTYPE=squashfs
+
 SQUASHFS_DIR=$(BUILD_DIR)/squashfs2.1-r2
 SQUASHFS_SOURCE=squashfs2.1-r2.tar.gz
 SQUASHFS_SITE=http://dl.sourceforge.net/sourceforge/squashfs
@@ -38,7 +40,7 @@ squashfs-dirclean:
 squashfsroot: squashfs
        @rm -rf $(TARGET_DIR)/usr/man
        @rm -rf $(TARGET_DIR)/usr/info
-       $(SQUASHFS_DIR)/squashfs-tools/mksquashfs $(TARGET_DIR) $(IMAGE).squashfs -noappend -root-owned -le
+       $(SQUASHFS_DIR)/squashfs-tools/mksquashfs $(TARGET_DIR) $(IMAGE).$(ROOTFSTYPE) -noappend -root-owned -le
 
 squashfsroot-source: squashfs-source
 
@@ -48,3 +50,13 @@ squashfsroot-clean:
 squashfsroot-dirclean:
        rm -rf $(SQUASHFS_DIR)
 
+openwrt-linux.trx.$(ROOTFSTYPE):
+       $(BUILD_DIR)/trx -o openwrt-linux.trx.$(ROOTFSTYPE) $(LINUX_DIR)/$(LINUX_BINLOC) $(IMAGE).$(ROOTFSTYPE)
+
+openwrt-gs-code.bin.$(ROOTFSTYPE): openwrt-linux.trx.$(ROOTFSTYPE)
+       $(BUILD_DIR)/addpattern -2 -i  openwrt-linux.trx.$(ROOTFSTYPE) -o openwrt-gs-code.bin.$(ROOTFSTYPE) -g
+
+openwrt-g-code.bin.$(ROOTFSTYPE): openwrt-gs-code.bin.$(ROOTFSTYPE)
+       sed -e "1s,^W54S,W54G," < openwrt-gs-code.bin.$(ROOTFSTYPE) > openwrt-g-code.bin.$(ROOTFSTYPE)
+
+openwrt-image: openwrt-g-code.bin.$(ROOTFSTYPE)