ramips: add kernel support for the Edimax BR-6425 board
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Feb 2013 17:01:47 +0000 (17:01 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Feb 2013 17:01:47 +0000 (17:01 +0000)
Signed-off-by: Yuval Adam <yuv.adm@gmail.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35462 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-br6425.c [new file with mode: 0644]
target/linux/ramips/rt305x/config-3.7

index 384a466..238495d 100644 (file)
@@ -41,6 +41,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_ALL0239_3G,         /* ALL0239-3G */
        RAMIPS_MACH_ARGUS_ATP52B,       /* Argus ATP-52B */
        RAMIPS_MACH_BC2,                /* NexAira BC2 */
+       RAMIPS_MACH_BR6425,             /* Edimax BR-6425 */
        RAMIPS_MACH_BROADWAY,           /* Hauppauge Broadway */
        RAMIPS_MACH_DAP_1350,           /* D-Link DAP-1350 */
        RAMIPS_MACH_ESR_9753,           /* Senao / EnGenius ESR-9753*/
index 97258de..c4653f5 100644 (file)
@@ -17,6 +17,11 @@ config RT305X_MACH_3G300M
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_BR6425
+       bool "Edimax BR-6425 board support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_WR6202
        bool "Accton WR6202"
        select RALINK_DEV_GPIO_BUTTONS
index d38765c..4e9f2f7 100644 (file)
@@ -18,6 +18,7 @@ obj-$(CONFIG_RT305X_MACH_BC2)         += mach-bc2.o
 obj-$(CONFIG_RT305X_MACH_AIR3GII)      += mach-air3gii.o
 obj-$(CONFIG_RT305X_MACH_ALL0256N)     += mach-all0256n.o
 obj-$(CONFIG_RT305X_MACH_ALL5002)      += mach-all5002.o
+obj-$(CONFIG_RT305X_MACH_BR6425)       += mach-br6425.o
 obj-$(CONFIG_RT305X_MACH_BROADWAY)     += mach-broadway.o
 obj-$(CONFIG_RT305X_MACH_CARAMBOLA)    += mach-carambola.o
 obj-$(CONFIG_RT305X_MACH_DIR_300_REVB) += mach-dir-300-revb.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-br6425.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-br6425.c
new file mode 100644 (file)
index 0000000..3a24516
--- /dev/null
@@ -0,0 +1,78 @@
+/*
+ *  Edimax BR-6425 board support
+ *
+ *  Copyright (C) 2012 OpenWrt.org
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define BR6425_GPIO_LED_POWER          9
+#define BR6425_GPIO_BUTTON_RESET       12
+#define BR6425_GPIO_SWITCH_RFKILL      13
+#define BR6425_GPIO_LED_WLAN           14
+#define BR6425_KEYS_POLL_INTERVAL      20
+#define BR6425_KEYS_DEBOUNCE_INTERVAL  (3 * BR6425_KEYS_POLL_INTERVAL)
+
+static struct gpio_keys_button br6425_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset_wps",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = BR6425_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = BR6425_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       },
+       {
+               .desc           = "RFKILL switch",
+               .type           = EV_SW,
+               .code           = KEY_RFKILL,
+               .debounce_interval = BR6425_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = BR6425_GPIO_SWITCH_RFKILL,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_led br6425_leds_gpio[] __initdata = {
+       {
+               .name           = "edimax:green:power",
+               .gpio           = BR6425_GPIO_LED_POWER,
+               .active_low     = 1,
+       }, {
+               .name           = "edimax:orange:wlan",
+               .gpio           = BR6425_GPIO_LED_WLAN,
+               .active_low     = 1,
+       },
+};
+
+static void __init br6425_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+       rt305x_register_flash(0);
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_LLLLW;
+       rt305x_register_ethernet();
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(br6425_leds_gpio),
+                                 br6425_leds_gpio);
+       ramips_register_gpio_buttons(-1, BR6425_KEYS_POLL_INTERVAL,
+                                    ARRAY_SIZE(br6425_gpio_buttons),
+                                    br6425_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_BR6425, "BR-6425", "Edimax BR-6425",
+            br6425_init);
index db31937..831219c 100644 (file)
@@ -109,6 +109,7 @@ CONFIG_RT305X_MACH_ALL0256N=y
 CONFIG_RT305X_MACH_ALL5002=y
 CONFIG_RT305X_MACH_ARGUS_ATP52B=y
 CONFIG_RT305X_MACH_BC2=y
+CONFIG_RT305X_MACH_BR6425=y
 CONFIG_RT305X_MACH_BROADWAY=y
 CONFIG_RT305X_MACH_CARAMBOLA=y
 CONFIG_RT305X_MACH_DAP_1350=y