kernel: add kirkwood thermal module
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Oct 2013 16:26:55 +0000 (16:26 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Oct 2013 16:26:55 +0000 (16:26 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38371 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/other.mk

index 65f2975..453bedf 100644 (file)
@@ -824,3 +824,20 @@ define KernelPackage/thermal-imx/description
 endef
 
 $(eval $(call KernelPackage,thermal-imx))
+
+
+define KernelPackage/thermal-kirkwood
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Temperature sensor on Marvell Kirkwood SoCs
+  DEPENDS:=@TARGET_kirkwood +kmod-thermal
+  KCONFIG:=CONFIG_KIRKWOOD_THERMAL
+  FILES:=$(LINUX_DIR)/drivers/thermal/kirkwood_thermal.ko
+  AUTOLOAD:=$(call AutoProbe,kirkwood_thermal)
+endef
+
+define KernelPackage/thermal-kirkwood/description
+ Support for the Kirkwood thermal sensor driver into the Linux thermal
+ framework. Only kirkwood 88F6282 and 88F6283 have this sensor.
+endef
+
+$(eval $(call KernelPackage,thermal-kirkwood))