gdb: use the libthread-db package instead of throwing the lib into the gdbserver...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 29 Oct 2012 19:25:34 +0000 (19:25 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 29 Oct 2012 19:25:34 +0000 (19:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34000 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/devel/gdb/Makefile

index d9d69d9..50d12fc 100644 (file)
@@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/gdb/Default
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@!(avr32||cris)
+  DEPENDS:=@!(avr32||cris) +libthread-db
   URL:=http://www.gnu.org/software/gdb/
 endef
 
@@ -80,10 +80,6 @@ endef
 define Package/gdbserver/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
-ifneq ($(CONFIG_USE_EGLIBC),)
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(TOOLCHAIN_DIR)/lib/libthread_db* $(1)/usr/lib
-endif
 endef
 
 $(eval $(call BuildPackage,gdb))