[toolchain] eglibc: add support for 2.10 branch
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Sep 2009 18:59:22 +0000 (18:59 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Sep 2009 18:59:22 +0000 (18:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17748 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/eglibc/Config.in
toolchain/eglibc/Config.version
toolchain/eglibc/Makefile
toolchain/eglibc/config/Config.in

index 132f57f..80f4fde 100644 (file)
@@ -17,6 +17,9 @@ choice
        config EGLIBC_VERSION_2_9
                bool "eglibc 2.9"
 
+       config EGLIBC_VERSION_2_10_1
+               bool "eglibc 2.10.1"
+
        config EGLIBC_VERSION_TRUNK
                bool "eglibc trunk"
 
@@ -30,6 +33,7 @@ config EGLIBC_REVISION
        default "8588"  if EGLIBC_VERSION_2_7
        default "8587"  if EGLIBC_VERSION_2_8
        default "8690"  if EGLIBC_VERSION_2_9
+       default "8873"  if EGLIBC_VERSION_2_10_1
        default "HEAD"  if EGLIBC_VERSION_TRUNK
        default ""
 
index edee7cc..00b3722 100644 (file)
@@ -5,5 +5,13 @@ config EGLIBC_VERSION
        default "2.7"    if EGLIBC_VERSION_2_7
        default "2.8"    if EGLIBC_VERSION_2_8
        default "2.9"    if EGLIBC_VERSION_2_9
+       default "2.10.1" if EGLIBC_VERSION_2_10_1
        default "trunk"
 
+config EGLIBC_VERSION_2_6
+       bool
+       default y       if EGLIBC_VERSION_2_6_1
+
+config EGLIBC_VERSION_2_10
+       bool
+       default y       if EGLIBC_VERSION_2_10_1
index d237f4e..0363dd9 100644 (file)
@@ -27,6 +27,9 @@ endif
 ifeq ($(PKG_VERSION),2.9)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_9
 endif
+ifeq ($(PKG_VERSION),2.10.1)
+  PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_10
+endif
 ifeq ($(PKG_VERSION),trunk)
   PKG_SOURCE_URL:=svn://svn.eglibc.org/trunk
 endif
index f67ae45..003362b 100644 (file)
@@ -187,6 +187,31 @@ config EGLIBC_OPTION_EGLIBC_ENVZ
         envz_entry      envz_remove
         envz_get        envz_strip 
 
+config EGLIBC_OPTION_EGLIBC_FCVT
+   bool "Functions for converting floating-point numbers to strings"
+   default y
+   depends EGLIBC_VERSION_2_10
+   help
+       This option group includes functions for converting
+       floating-point numbers to strings.
+
+       This option group includes the following functions:
+
+         ecvt           qecvt
+         ecvt_r         qecvt_r
+         fcvt           qfcvt
+         fcvt_r         qfcvt_r
+         gcvt           qgcvt
+
+config EGLIBC_OPTION_EGLIBC_FMTMSG
+   bool "Functions for formatting messages"
+   default y
+   depends EGLIBC_VERSION_2_10
+   help
+       This option group includes the following functions:
+
+         addseverity    fmtmsg
+
 config EGLIBC_OPTION_EGLIBC_FSTAB
    bool "Access functions for 'fstab'"
    default y
@@ -202,6 +227,22 @@ config EGLIBC_OPTION_EGLIBC_FSTAB
          getfsent       setfsent
          getfsfile
 
+config OPTION_EGLIBC_FTRAVERSE
+   bool "Functions for traversing file hierarchies"
+   default y
+   depends EGLIBC_VERSION_2_10
+   help
+       This option group includes functions for traversing file
+       UNIX file hierachies.
+
+       This option group includes the following functions:
+
+         fts_open       ftw
+         fts_read       nftw
+         fts_children   ftw64
+         fts_set        nftw64
+         fts_close
+
 config EGLIBC_OPTION_EGLIBC_GETLOGIN
    bool "The getlogin function"
    default y
@@ -678,6 +719,19 @@ config EGLIBC_OPTION_POSIX_REGEXP
         <regexp.h> header file, 'compile', 'step', and 'advance', is
         omitted.
 
+config EGLIBC_OPTION_POSIX_REGEXP_GLIBC
+   bool "Regular expressions from GLIBC"
+   default y
+   depends EGLIBC_OPTION_POSIX_REGEXP
+   depends EGLIBC_VERSION_2_10
+   help
+        This option group specifies which regular expression
+        library to use.  The choice is between regex
+        implementation from GLIBC and regex implementation from
+        libiberty.  The GLIBC variant is fully POSIX conformant and
+        optimized for speed; regex from libiberty is more than twice
+        as small while still is enough for most practical purposes.
+
 config EGLIBC_OPTION_POSIX_WIDE_CHAR_DEVICE_IO
    bool "Input and output functions for wide characters"
    default y