[packages] kernel: Add kernel module for OMAP WDT
authorhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 Oct 2010 08:50:43 +0000 (08:50 +0000)
committerhcg <hcg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 Oct 2010 08:50:43 +0000 (08:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23689 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk

index 53080f8..b5b659a 100644 (file)
@@ -680,6 +680,22 @@ endef
 $(eval $(call KernelPackage,wdt-geode))
 
 
+define KernelPackage/wdt-omap
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=OMAP Watchdog timer
+  DEPENDS:=@(TARGET_omap24xx||TARGET_omap35xx)
+  KCONFIG:=CONFIG_OMAP_WATCHDOG
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/omap_wdt.ko
+  AUTOLOAD:=$(call AutoLoad,50,omap_wdt.ko)
+endef
+
+define KernelPackage/wdt-omap/description
+  Kernel module for TI omap watchdog timer.
+endef
+
+$(eval $(call KernelPackage,wdt-omap))
+
+
 define KernelPackage/wdt-sc520
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Natsemi SC520 Watchdog support