ramips: use correct parameters in the Seama template
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 23 Aug 2013 17:07:26 +0000 (17:07 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 23 Aug 2013 17:07:26 +0000 (17:07 +0000)
Fixes DIR-645 image generation errors:

  bash: line 0: [: wrgn39_dlob.hans_dir645: integer expression expected
  ...
  bash: wrgn39_dlob.hans_dir645 - 64: syntax error: invalid arithmetic operator (error token is ".hans_dir645 - 64")  make[4]: *** [install] Error 1

Signed-off-by: Michael Lee <igvtee@gmail.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37828 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/image/Makefile

index 18f0fe5..ba7f660 100644 (file)
@@ -156,9 +156,9 @@ BuildFirmware/Edimax/initramfs=$(call BuildFirmware/OF/initramfs,$(1),$(2),$(3))
 
 # build Seama header images
 define BuildFirmware/Seama/squashfs
 
 # build Seama header images
 define BuildFirmware/Seama/squashfs
-       $(call BuildFirmware/OF,$(1),$(2),$(3),$(4))
+       $(call BuildFirmware/OF,$(1),$(2),$(3),$(5))
        cat $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/root.$(1) > $(KDIR)/img_$(2).$(1).tmp
        cat $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/root.$(1) > $(KDIR)/img_$(2).$(1).tmp
-       if [ `stat -c%s "$(KDIR)/img_$(2).$(1).tmp"` -gt $$$$(($(4) - 64)) ]; then \
+       if [ `stat -c%s "$(KDIR)/img_$(2).$(1).tmp"` -gt $$$$(($(5) - 64)) ]; then \
                echo "Warning: $(KDIR)/img_$(2).$(1).tmp is too big" >&2; \
        else \
                dd if=$(KDIR)/vmlinux-$(2).bin.lzma of=$(KDIR)/vmlinux-$(2).bin.lzma.padded bs=64k conv=sync; \
                echo "Warning: $(KDIR)/img_$(2).$(1).tmp is too big" >&2; \
        else \
                dd if=$(KDIR)/vmlinux-$(2).bin.lzma of=$(KDIR)/vmlinux-$(2).bin.lzma.padded bs=64k conv=sync; \