kernel.mk: Handle the x86_64 LINUX_KARCH case
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Dec 2014 18:28:13 +0000 (18:28 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Dec 2014 18:28:13 +0000 (18:28 +0000)
x64 is handled by the x86 architecture in Linux, add a case for it in
LINUX_KARCH.

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43672 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk

index b905cb9..eeb0c3d 100644 (file)
@@ -72,7 +72,7 @@ else ifneq (,$(findstring $(ARCH), mipsel mips64 mips64el))
   LINUX_KARCH := mips
 else ifneq (,$(findstring $(ARCH), sh2 sh3 sh4))
   LINUX_KARCH := sh
-else ifneq (,$(findstring $(ARCH), i386))
+else ifneq (,$(findstring $(ARCH), i386 x86_64))
   LINUX_KARCH := x86
 else
   LINUX_KARCH := $(ARCH)