atheros: trailing statements fixes
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Jun 2014 09:06:10 +0000 (09:06 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Jun 2014 09:06:10 +0000 (09:06 +0000)
Move trailing statements to next line with indentation as suggested by
checkpatch.

Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41092 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/atheros/patches-3.10/100-board.patch
target/linux/atheros/patches-3.10/101-early-printk-support.patch
target/linux/atheros/patches-3.10/110-ar2313_ethernet.patch
target/linux/atheros/patches-3.10/230-3_10-updates.patch

index 33c7ce5..07b8145 100644 (file)
@@ -84,7 +84,7 @@
 +obj-$(CONFIG_ATHEROS_AR2315) += ar2315.o
 --- /dev/null
 +++ b/arch/mips/ar231x/board.c
-@@ -0,0 +1,260 @@
+@@ -0,0 +1,261 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 + * License.  See the file "COPYING" in the main directory of this archive
 +ar231x_halt(void)
 +{
 +      local_irq_disable();
-+      while (1);
++      while (1)
++              ;
 +}
 +
 +void __init
index 2346e24..3daa011 100644 (file)
@@ -1,6 +1,6 @@
 --- /dev/null
 +++ b/arch/mips/ar231x/early_printk.c
-@@ -0,0 +1,44 @@
+@@ -0,0 +1,46 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 + * License.  See the file "COPYING" in the main directory of this archive
 +                      base = (void __iomem *)(KSEG1ADDR(AR531X_UART0));
 +      }
 +
-+      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
++              ;
 +      prom_uart_wr(base, UART_TX, ch);
-+      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0);
++      while ((prom_uart_rr(base, UART_LSR) & UART_LSR_THRE) == 0)
++              ;
 +}
 +
 --- a/arch/mips/ar231x/Makefile
index 1fc4eb4..b283e31 100644 (file)
@@ -32,7 +32,7 @@
 +obj-$(CONFIG_NET_VENDOR_AR231X) += ar231x.o
 --- /dev/null
 +++ b/drivers/net/ethernet/ar231x/ar231x.c
-@@ -0,0 +1,1255 @@
+@@ -0,0 +1,1257 @@
 +/*
 + * ar231x.c: Linux driver for the Atheros AR231x Ethernet device.
 + *
 +      volatile ETHERNET_STRUCT *ethernet = sp->phy_regs;
 +
 +      ethernet->mii_addr = MII_ADDR(phy_addr, regnum);
-+      while (ethernet->mii_addr & MII_ADDR_BUSY);
++      while (ethernet->mii_addr & MII_ADDR_BUSY)
++              ;
 +      return ethernet->mii_data >> MII_DATA_SHIFT;
 +}
 +
 +      struct ar231x_private *sp = netdev_priv(dev);
 +      volatile ETHERNET_STRUCT *ethernet = sp->phy_regs;
 +
-+      while (ethernet->mii_addr & MII_ADDR_BUSY);
++      while (ethernet->mii_addr & MII_ADDR_BUSY)
++              ;
 +      ethernet->mii_data = value << MII_DATA_SHIFT;
 +      ethernet->mii_addr = MII_ADDR(phy_addr, regnum) | MII_ADDR_WRITE;
 +
index 8e4db17..f1adf82 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/ethernet/ar231x/ar231x.c
 +++ b/drivers/net/ethernet/ar231x/ar231x.c
-@@ -1272,7 +1272,7 @@ static int ar231x_mdiobus_probe(struct n
+@@ -1274,7 +1274,7 @@ static int ar231x_mdiobus_probe(struct n
        BUG_ON(!phydev);
        BUG_ON(phydev->attached_dev);